OMSA: 10.3 is Not Updating Self-signed SSL Certificates for the Web UI After Upgrade from a Previous OMSA Version
Summary: Dell OpenManage Server Administrator (OMSA) 10.3.0 and earlier does not update the default self-signed SSL certificate necessary for the web UI. If the previous OMSA version was installed more than two years ago, the certificate valid date range may have expired. ...
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Symptoms
It may be noted when connecting a web browser to the Dell OpenManage Server Administrator 10.3.0 web UI that the SSL certificate’s valid date range may already have expired.
Cause
OMSA upgrades are not creating a new self-signed certificate with a new valid date range starting with the date of upgrade.
Resolution
Dell Engineering plans to address this issue in a future OMSA version where a default self-signed certificate was automatically created during a previous OMSA installation. If a custom self-signed certificate or a certificate generated by a certificate authority was imported, an OMSA upgrade does not replace that custom certificate.
A possible workaround is to use the OMSA command-line to create a new self-signed certificate with the following syntax:
A possible workaround is to use the OMSA command-line to create a new self-signed certificate with the following syntax:
omconfig preferences webserver attribute=<gennewcert> cn=<common name> org=<organization name> ou=<organization unit name> location=<location name> state=<state name> country=<country name> webserverrestart=trueThere are other optional certificate parameters that can be added to this syntax including:
validity=<days_to_expiration>Consult the Dell OpenManage Server Administrator Command-Line Interface Guide for usage and further options
Affected Products
OpenManage Server Administrator, Dell OpenManage Server Administrator Version 10.2.0.0, Dell OpenManage Server Administrator Version 10.3.0.0Article Properties
Article Number: 000222995
Article Type: Solution
Last Modified: 14 Aug 2025
Version: 2
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