Open Server Manager: Health Rollup Status Not Auto Cleared
Summary: Dell Open Server Manager (OSM) Health Rollup remains critical status after error or warning condition is remediated.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Dell Open Server Manager (OSM) Health Rollup Status changes to critical anytime that a warning or critical event is recorded in the event log. The status remains critical until the end user deletes the complete event log from the BMC log. Deleting individual events is not supported in OSM. Sometimes, the server identifier LED remains in fault (amber) condition until the status is returned to normal.
Health Rollup Critical Example:
The example excerpt above demonstrates that AC power was lost and restored to power supply 1. While the event log reflects that the input power has been restored, the server health continues to reflect critical error in top ribbon. The Health Rollup continues to report critical status until the entire event log is deleted.
Health Rollup Critical Example:
The example excerpt above demonstrates that AC power was lost and restored to power supply 1. While the event log reflects that the input power has been restored, the server health continues to reflect critical error in top ribbon. The Health Rollup continues to report critical status until the entire event log is deleted.
Cause
This behavior is expected in the OpenBMC OpenSource firmware stack. In order to return server health to normal, the end user must acknowledge the error condition and delete the complete event log.
Resolution
In order to remediate the critical condition, the OSM end user must delete the complete BMC event log.
Note: It is recommended to export the BMC Event logs or export a Technical Support Report (TSR) before deleting the event log.
OSM UI >> Logs >> Event Logs Example:
REDFISH Example:
Note: It is recommended to export the BMC Event logs or export a Technical Support Report (TSR) before deleting the event log.
OSM UI >> Logs >> Event Logs Example:
REDFISH Example:
POST …/redfish/v1/Systems/system/LogServices/EventLog/Actions/LogService.ClearLog
{
"@Message.ExtendedInfo": [
{
"@odata.type": "#Message.v1_1_1.Message",
"Message": "The request completed successfully.",
"MessageArgs": [
],
"MessageId": "Base.1.13.0.Success",
"MessageSeverity": "OK",
"Resolution": "None"
}
]
}
Affected Products
Open Server ManagerProducts
PowerEdge R470, PowerEdge R670, PowerEdge R770, PowerEdge R7715, PowerEdge R7725Article Properties
Article Number: 000226514
Article Type: Solution
Last Modified: 28 Jan 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.