SyncIQ fails with error: Maximum file name length support differs
Summary: A SyncIQ job fails when Long Filename (LFN) support is enabled on a source or target cluster while not enabled on the peer cluster.
Symptoms
SyncIQ fails with error: "Maximum file name length support differs between the source and target. Cannot sync a cluster with long file names to a target cluster without long name support enabled"
Cause
A SyncIQ job fails if LFN is enabled on only one cluster, source, or target, in a SyncIQ relationship.
On OneFS, the default name length defaults are 255 Bytes in length and 255 characters. Both clusters in a SyncIQ relationship must be able to support Long Filenames (LFN) that exceed the default maximum.
Resolution
Check whether LFN is enabled on both source and target clusters:
# isi_for_array -s 'sysctl efs.bam.long_file_name_enabled'
Check the LFN setting for SyncIQ's source and target paths:
# isi sync policies view <policy_name> |grep Path:
# isi namelength list
Enable LFN on the cluster:
# isi_sysctl_cluster efs.bam.long_file_name_enabled=1 --explanation="Enable LFN"
Example command:
# isi namelength create --max-bytes xxxx --max-chars xxxx /ifs/<lfn_path>Additional Information
LFN was introduced in OneFS 9.3.
More information: http://www.unstructureddatatips.com/onefs-and-long-filenames/