PowerFlex 2.x GUI visar ingen information om frontend eller backend

Summary: ScaleIO-gränssnittet visar ingen information om frontend eller backend

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Problembeskrivning

Efter några dagar till några veckor visar backend- och frontend-vyerna i användargränssnittet bara en laddningsikon i stället för den förväntade informationen. 

Scenario

Användargränssnittet börjar märka att SDS-, SDC- och volymvyerna hänger sig efter en viss tid.

Symptom

Följande skärmbilder är vad som kan ses i antingen frontend- eller backend-vyerna när det här problemet uppstår:

frontend 

grafiskt användargränssnitt 

 

I gränssnittsloggarna från "%appdata%\EMC\scaleio\logs\log.txt" kan tusentals av följande inträffa:

java.util.concurrent.TimeoutException: Det gick inte att få fullständigt QueryPoll-svar i 10 000 begäranden

 

Påverkan

Det går inte att hantera eller övervaka ScaleIO-systemet från användargränssnittet.  

Cause

Rotorsaken till det här problemet är när det finns tusen+ skapande och borttagningar av volymer (vtrees) under en tidsperiod där antalet volymer som fortfarande finns i ScaleIO-systemet är över 1000+. Detta påverkar användargränssnittet FilterController som används av BaseTreeTablePanel som används av både serverdels- och frontend-vyer, och avgör även när backend- och frontend-vyerna slutligen visas. Eftersom användargränssnittet aldrig får en fullständig modell fortsätter inläsningsbilden att snurra tills modellen har lästs in helt.

Den här typen av problem kan ses i OpenStack-distributioner eftersom det finns många skapa/mappa/avmappa/radera-händelser på volymer på grund av snapshots i OpenStack. 

Resolution

 

Den aktuella lösningen är att utföra ett MDM-ägarskap med sci: 

scli --switch_mdm_ownership --new_master_mdm_id <ID of Slave MDM>

 

Berörda versioner

2.0.1.3, 2.0.1.4, 2.5, 2.6

Åtgärdat i version

2.6.1, 3.0

Article Properties
Article Number: 000164011
Article Type: Solution
Last Modified: 28 Aug 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.