SourceOne Email Management: Index transaction files in DropDir causing processing delays

Summary: Index transaction files in DropDir causing processing delays

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Symptoms



SourceOne Email Management index update (UPDS) transaction files in the DropDir folder are not processing and causing index delays and backlog of processing.
Errors are reported in the ExAsIdxObj.exe.log files on the index servers regarding unable to find index in SQL.
Due to UPDS files using up index threads but not processing it causes other indexing activity to queue in the environment.

Cause

This issue is due to index transaction files being moved out of the DropDir and then attempting to reprocess (move back) after the index was disposed from the archive.  This leaves the UPDS files stuck in a state waiting for the index to exist in the archive before they are processed.

Resolution

This issue should never occur under normal operation and would only be encountered if the UPDS files are manually moved back to the DropDir after the archive/index content has already been deleted from SourceOne.

Manually removing the offending files from the DropDir resolves the issue.

Affected Products

SourceOne Email Management

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000055954
Article Type: Solution
Last Modified: 26 May 2025
Version:  5
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