Dell Data Protection Encryption installer 1303 error

Summary: This article describes an issue with an Installer error "Error 1303.The installer has insufficient privileges to access this directory: C:\Program Files\Dell\Dell Data Protection\Encryption\Local Console." ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • Dell Data Protection | Encryption

The MSI log file contains the following error log entry. A dialog box also appears with the same message:

Error 1303.The installer has insufficient privileges to access this directory: C:\Program Files\Dell\Dell Data Protection\Encryption\Local Console. The installation cannot continue. Log on as an administrator or contact your system administrator.

Cause

When performing a major upgrade (for example, from v7.x to 8.x or v8.2.x to 8.3.x), a file become locked after the installer performs its initial check to ensure that all files are available. This results in an error that leaves the Shield partially uninstalled that cannot be uninstalled, repaired, or upgraded.

The Dell Data Protection | Encryption 8.2.1.8591 client drop has code to treat all upgrades as a major upgrade that can also trigger this issue.

Resolution

Use the following command line to partially recover the installed Shield. It is not in a functional state, but it allows a subsequent uninstall and reinstall to get everything working.

DDPE_64bit_setup.exe /v"EXIST_PROD_VERSION=5.2.0.3761 /l*v install.log

To contact support, reference Dell Data Security International Support Phone Numbers.
Go to TechDirect to generate a technical support request online.
For additional insights and resources, join the Dell Security Community Forum.

Affected Products

Dell Encryption
Article Properties
Article Number: 000125048
Article Type: Solution
Last Modified: 03 Apr 2024
Version:  8
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