Avamar: Il backup del file system di Windows ha esito negativo con il messaggio "Fatal server connection problem"

Summary: Questo articolo della Knowledge Base (KB) fornisce una soluzione per gli errori di backup del file system Windows di Avamar dovuti a errori di connessione.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Il primo backup di un client Windows ha esito negativo con i seguenti messaggi di errore nel registro: 

avtar Info <5552>: Connecting to Avamar Server (DELL01)
avtar Info <5554>: Connecting to one node in each datacenter
avtar Info <6063>: - Communication error: Could not create connection to Server
avtar Info <5557>: No connections available
avtar FATAL <8604>: Fatal server connection problem, aborting initialization.   Specify correct server address and login credentials.
avtar FATAL <8941>: Failed to initiate connection with server due to earlier errors.   Verify server address and login credentials.
avtar Info <6149>: Error summary: 2 errors: 8604, 8941
avtar Info <8468>: Sending wrapup message to parent
avtar Info <5314>: Command failed (2 errors, exit code 10008: cannot establish connection with server (possible network or DNS failure))

Cause

Il processo di Avtar.exe non è in grado di stabilire una connessione all'Avamar Utility Node a causa di un problema di risoluzione del DNS (Domain Naming System).

Resolution

  1. Verificare che il client Windows sia in grado di risolvere correttamente il nome di dominio completo (FQDN) dell'Avamar Utility Node nel relativo indirizzo IP. Questa operazione può essere eseguita utilizzando un record A dell host DNS sul server DNS in cui viene risolto il client. In alternativa, modificare il file dei local host (in genere C:\Windows\System32\drivers\etc) e aggiungere l'FQDN e l'indirizzo IP dell'Avamar Server.
  2. Il problema potrebbe anche essere dovuto al valore "--hfsaddr" nel file mcserver.xml che punta al nome breve anziché al nome di dominio completo della griglia Avamar. Il supporto Avamar deve eseguire i seguenti passaggi:
    1. Correggere il valore hfsaddr in mcserver.xml all FQDN della griglia Avamar utilizzando l'editor Vi. Il file si trova nella directory "/usr/local/avamar/var/mc/server_data/prefs" sull'Avamar Server.
    2. Riavviare il servizio Management Console Service (MCS) digitando i comandi riportati nell'articolo della Knowledge Base Avamar: Come riavviare il server Management Console.
    3. Quindi riprovare a eseguire il backup del file system.
  3. Se le opzioni precedenti non risolvono il problema, controllare la modalità di crittografia se si esegue il backup su Data Domain. Se è impostato su "none", modificarlo in "High" e riprovare a eseguire il backup.

Additional Information

Il riavvio del servizio MCS sulla griglia Avamar cancella la cronologia dei processi di backup nella finestra Activity di Avamar Administrator.

Affected Products

Avamar Client for Windows, Avamar Server, Data Domain
Article Properties
Article Number: 000038622
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.