NetWorker Module for Databases and Applications 9.x wizard RMAN restore fails with message ORA-12514
Summary: NetWorker Module for Databases and Applications (NMDA) 9.x wizard Oracle Recovery Manager (RMAN) restore fails with message ORA-12514.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
When creating an RMAN restore using the NMDA 9.x wizard, restoring back to the original database as the backup source may fail with the following error:
RMAN-00571: =========================================================== RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS =============== RMAN-00571: =========================================================== RMAN-03002: failure of startup command at 01/13/2017 19:32:34 ORA-12514: TNS:listener does not currently know of service requested in connect descriptor Recovery Manager complete.
Cause
This issue may occur when selecting Yes during the wizard option, Do you want the software to shut down the target database and start the database in mount mode before performing the recovery? If the users select Yes, and are using Oracle Database Authentication to connect to the target database, the Oracle listener must have a valid entry for the target database.
Resolution
Use the Oracle
For example:
netmgr or netca tool to add a database listening location for the target database. To ensure this is done correctly, you can verify by connecting to the target database with CLI, while the database is down.
For example:
PS C:\> rman target user/passwd@SID Recovery Manager: Release 12.1.0.2.0 - Production on Thu Jan 19 16:01:11 2017 Copyright (c) 1982, 2014, Oracle and/or its affiliates. All rights reserved. connected to target database (not started) RMAN>Alternatively, use OS authentication to connect to the target database (for UNIX or Linux), or do not shut down the target database during the wizard options.
Article Properties
Article Number: 000056705
Article Type: Solution
Last Modified: 22 Sept 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.