Backup is failing due to not having enough devices to service requests
Summary: Not having adequate number of devices (or target sessions per device) results in backup failure
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Symptoms
Backup fails with symptoms below indicating device being busy and unable to complete backups
Error: 'ORA-19511: non RMAN, but media manager or vendor specific failure, error text: busy (0:5:2)'
Error:'ORA-19511: Error received from media manager layer, error text: busy (0:5:2)'
Error: '_nwbsa_is_retryable_error received a retryable network error (Severity 0 Number -13) busy'
Error: 'nsrdasv: Failed to acquire user credentials for direct save nsrmmd auth: busy'
Error: 'save: Unable to setup direct save with server nsr_server.domain.com: busy.'
Error: 'hdbbackint: Unable to setup direct save with server nsr_server.domain.com: busy.'
Error: 'lgto_auth for `nsrmmd' failed: busy'
Cause
Problem is usually caused by when device is busy servicing other clients.
Resolution
Problem can be resolved by following
1. Disable dynamic nsrmmds
NMC > Devices > Storage Nodes > select Properties of the storage node > uncheck 'Dynamic nsrmmds'
2. Increase target sessions of the device until problem is resolved
3. Make more volumes (devices) available for backup until problem is resolved
4. set NSR_MAX_START_RETRIES=100 fro each channel
1. Disable dynamic nsrmmds
NMC > Devices > Storage Nodes > select Properties of the storage node > uncheck 'Dynamic nsrmmds'
2. Increase target sessions of the device until problem is resolved
3. Make more volumes (devices) available for backup until problem is resolved
4. set NSR_MAX_START_RETRIES=100 fro each channel
Affected Products
NetWorker Module for Databases and ApplicationsProducts
NetWorker, NetWorker Module for Databases and Applications, NetWorker Module for SAPArticle Properties
Article Number: 000167090
Article Type: Solution
Last Modified: 25 Apr 2025
Version: 3
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