Isilon: Generazione 6: Il nodo non si avvia con messaggio di errore "Unable to perform receipt update for Hardware Upgrade"

Summary: Il nodo Gen6 non si avvia durante la fase di configurazione PSI e viene visualizzato lo script "isi_upgrade_hardware" in esecuzione, seguito da un messaggio di errore "Unable to perform receipt update for Hardware Upgrade". ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Il nodo Gen6 non si avvia durante la fase di configurazione PSI e viene visualizzato lo script "isi_upgrade_hardware" in esecuzione, seguito da un messaggio di errore "Unable to perform receipt update for Hardware Upgrade". Ciò può verificarsi dopo un recente aggiornamento dell'hardware del cluster, ad esempio un aggiornamento di DIMM, NIC o SSD. La fine della sequenza di avvio sarà simile alla seguente (le righe importanti sono in grassetto):

2021-05-05T11:55:15-07:00 isi_upgrade_hardware[470]: Aggiornare la ricevuta per l'upgrade dell'hardware
2021-05-05T11:55:15-07:00 isi_upgrade_hardware[470]: Aggiornamento della ricevuta - cmd: /usr/bin/isi_hwtools/isi_json_update /mfg/psi/receipt.json FE 002-iFEIO-10GBE-B-psi
2021-05-05T11:55:15-07:00 isi_upgrade_hardware[470]: Aggiornamento della ricevuta - cmd: /usr/bin/isi_hwtools/isi_json_update /mfg/psi/receipt.json MODEL_BOM,compute 001-infinity-compute-low-64GB-psi
2021-05-05T11:55:15-07:00 isi_upgrade_hardware[470]: Aggiornamento della ricevuta - cmd: /usr/bin/isi_hwtools/isi_json_update /mfg/psi/receipt.json MODEL_BOM,ssd 001-infinity-ssd-1x400gb-psi
2021-05-05T11:55:15-07:00 isi_upgrade_hardware[470]: Passaggio successivo - Eseguire isi_upgrade_hardware --node --validate
2021-05-05T11:55:15-07:00 isi_upgrade_hardware[470]: Automatic Replacement Recognition già abilitato
2021-05-05T11:56:16-07:00 isi_upgrade_hardware[470]: Impossibile analizzare l'aggiornamento hardware gconfig: (aggiornamento in hwupgrade.upgrades): Nessun file o directory
di questo tipo2021-05-05T11:56:16-07:00 pitone: [520] ATTENZIONE: Errore IPMI: rv=0, CC=0xc1. Indirizzo IPMB: 0x20 cmd: 0xbf, netfn: 0x30, dati cmd: [01]
2021-05-05T11:56:16-07:00 pitone: [520] ATTENZIONE: CC[c1]: Comando non valido.
2021-05-05T11:56:16-07:00 Python: bootstrap_get_minbay: minbay 1, maggiore 0, minore 0, ha aspettato 0 sec 6458 usec
Impossibile eseguire l'aggiornamento della ricevuta per l'aggiornamento dell'hardware
Per evitare una situazione di DL, contattare immediatamente il supporto clienti Dell EMC:

Cause

Il recente aggiornamento dell'hardware è stato eseguito utilizzando una versione precedente dello script isi_hardware_upgrade che conteneva un bug che impediva il completamento della fase di pulizia del processo. Il file /root/node_hardware_upgrade.json è stato lasciato sul nodo. Ciò induce il nodo a credere di essere ancora nel mezzo di un aggiornamento hardware e di tentare di eseguire il passaggio successivo del processo, che ha esito negativo perché in realtà non è ancora in corso un aggiornamento. Ciò impedirà al nodo di completare l'avvio.

Resolution

1. Prima di tutto, verificare con il cliente e il personale sul campo presente che non sia attualmente in corso un upgrade dell hardware. Quindi, dal menu della shell di ripristino, premere 1 per accedere alla shell di ripristino, quindi premere Invio per caricare la shell predefinita.

2. Verificare che nel nodo sia presente il seguente file: /root/node_hardware_upgrade.json

3. Se trovato, rinominare questo file, quindi riavviare il nodo:

# mv /root/node_hardware_upgrade.json /root/node_hardware_upgrade.json.bak
# reboot


4. Se il nodo si avvia correttamente, si consiglia di controllare preventivamente la presenza di questo file negli altri nodi del cluster e rimuoverlo se trovato:
# isi_for_array -s 'mv /root/node_hardware_upgrade.json /root/node_hardware_upgrade.json.bak'

Affected Products

Isilon, Isilon A200
Article Properties
Article Number: 000191007
Article Type: Solution
Last Modified: 26 Aug 2022
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.