NVP vProxy: VM backups failing with "no matching devices for save of client 'vCenter Name': check storage nodes, device, or pools"

Summary: Virtual Machines protected by the NVP vProxy appliance fail to backup, the backup action log states "no matching devices for save of client 'vCenter Name': check storage nodes, device, or pools" ...

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Symptoms

  • Virtual Machine backup fails soon after starting with the following error logged in the action log within the NetWorker management console:
DD/MM/YYYY HH:MM:SS Unable to process VM 'VM_NAME': no matching devices for save of client `VCENTER_NAME' check storage nodes, devices or pools
DD/MM/YYYY HH:MM:SS VM_NAME: Backup failed
NOTE: This same error can appear for other backup types (File system, Database, and so on). The steps in this KB can be used to troubleshoot this issue.

Cause

This is not a vProxy issue. The failure is occurring during device selection. The workflow is unable to reconcile a usable device. Either there is a communication issue between the existing NetWorker server, Storage Node, and device or there is a potential configuration conflict.

Resolution

1. Log in to the NetWorker Management Console (NMC).
2. Go to Protection->Policies, and select the Workflow from the left menu.
3. Make note of the Pool and Storage Node configured in the workflow's backup action:

pool and storage node set in the backup action

4. Go to Media->Media Pools and open the properties of the Pool that is used by the workflow.
5. In the Selection Criteria tab, make note of any devices with a checkmark. If there are any devices that are checked, this means that the pool is restricted to using only these devices. 

Pool selection criteria

NOTE: The device must be a Data Domain type device. For VMware protection using multiple devices in a single pool, each device must reside within the same Data Domain host.

6. Go to Devices->Devices and confirm that the devices that are checked in the selection criteria are mounted. A mounted device shows a volume label. 

device is mounted

NOTE: If the Volume Name column is empty, the device is unmounted. Right-click the device and select Mount. Monitor the Log and Alerts window for any issues mounting the device.

7. Open the device properties and ensure that the "read only" box is cleared:

device read only box is cleared

8. Go to Media->Disk Volumes, ensure that the volume is appendable.

disk volume is appendable

9. Go to Devices->Storage Nodes and confirm that the storage node noted in step 3 is in a "ready" state:

NetWorker storage node is ready and enabled

NOTE: nsrserverhost is the NetWorker server's local storage node. Any devices that are shown with a rd= prefix mean that they are configured through a "remote" NetWorker storage node. 

10. Go to Protection->Clients and open the client properties of the vCenter server's client resource.
11. In the Globals (2 of 2) tab, ensure that the storage node entries exist for the storage nodes that are used during VM backups of this vCenter. Multiple storage nodes can be listed, one entry per line.

image.png

NOTE: View->Diagnostic Mode must be enabled to see the Storage Nodes specifications in the client properties.

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000200894
Article Type: Solution
Last Modified: 19 Mar 2025
Version:  2
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