Avamar: Client Manager Server Summary tab shows "No Data Found"

Summary: Avamar Client Manager web application does not show any Avamar servers listed in the server summary, only the following message: "No Data Found."

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

After logging in to the Client Manager web application the Server Summary is shown the message, "No Data Found."

Cause

The ACMTrace.log is in the following directory:
/usr/local/avamar-tomcat/logs/ACMTrace.log

The ACMTrace.log has the following error:
2023-03-30 17:27:30,906 WARN  [pool-43-thread-1]-impl.WebServiceProxy: not able to get viewuser password
java.lang.NullPointerException
        at com.emc.avamar.acm.core.impl.WebServiceProxy.getViewUserPassword(WebServiceProxy.java:2646)
        at com.emc.avamar.acm.core.datasource.MCParameters.createInstance(MCParameters.java:34)
        at com.emc.avamar.acm.core.datasource.DataSourceManager.createConnectParameter(DataSourceManager.java:219)
        at com.emc.avamar.acm.core.datasource.DataSourceManager.getConnectParameter(DataSourceManager.java:186)
        at com.emc.avamar.acm.core.datasource.DataSourceManager.getMCConnection(DataSourceManager.java:84)
        at com.emc.avamar.acm.core.impl.SessionImpl.getConnection(SessionImpl.java:142)
        at com.emc.avamar.acm.core.finder.impl.AvamarGridFinderImpl.getGridSummary(AvamarGridFinderImpl.java:254)
        at com.emc.avamar.acm.action.overview.GridSummaryAction$LocalTask.call(GridSummaryAction.java:147)
        at com.emc.avamar.acm.action.overview.GridSummaryAction$LocalTask.call(GridSummaryAction.java:101)
        at java.util.concurrent.FutureTask.run(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)

The line in the log says it is not able to get the viewuser password from the mcsdk10 call.
This means that the viewuser password is corrupted or lost in memory in MCS.

Resolution

Run the change-passwords script to update viewuser, it can be the same password that is already being used or a new password.

The script restarts MCS to update all configuration files and MCS with the viewuser password.

Affected Products

Avamar
Article Properties
Article Number: 000212697
Article Type: Solution
Last Modified: 08 Jan 2026
Version:  3
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