Rocky Linux: Error "unknown property" while trying to change network interface properties
Summary: This article provides troubleshooting information for the error "Unable to save connection: connection. Autoconnect-ports: unknown property" while changing network interface properties. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
When the administrator tries to edit the network interface properties using nmtui, the following error is displayed:
"Unable to save connection: connection.autoconnect-ports: unknown property"

Below is an example of the errors observed when trying to configure the interface using nmcli:
[root@localhost pcap]# nmcli connection modify BCM57414-IntNIC1-P1-25Gb 802-3-ethernet.mtu 1500
Warning: nmcli (1.46.0) and NetworkManager (1.44.0) versions don't match. Restarting NetworkManager is advised.
Error: Failed to modify connection 'BCM57414-IntNIC1-P1-25Gb': connection.autoconnect-ports: unknown property
[root@localhost pcap]# nmcli connection modify BCM57414-IntNIC1-P1-25Gb 802-3-ethernet.mtu 9000
Warning: nmcli (1.46.0) and NetworkManager (1.44.0) versions don't match. Restarting NetworkManager is advised.
Error: Failed to modify connection 'BCM57414-IntNIC1-P1-25Gb': connection.autoconnect-ports: unknown property
In this example, the administrator tried to change the interface's MTU, but the same error occurs while trying to change another property.
Cause
The cause is not clear. For some reason, the Network Manager indicates a version mismatch.
Resolution
- Check
NetworkManagerandnmcliversions: Verify if theNetworkManagerandnmcliversions are matching. In the example below, the versions were matching:[root@localhost pcap]# rpm -qa | grep NetworkManager NetworkManager-libnm-1.46.0-4.el9_4.x86_64 NetworkManager-1.46.0-4.el9_4.x86_64 NetworkManager-wwan-1.46.0-4.el9_4.x86_64 NetworkManager-team-1.46.0-4.el9_4.x86_64 NetworkManager-wifi-1.46.0-4.el9_4.x86_64 NetworkManager-bluetooth-1.46.0-4.el9_4.x86_64 NetworkManager-adsl-1.46.0-4.el9_4.x86_64 NetworkManager-tui-1.46.0-4.el9_4.x86_64 NetworkManager-config-server-1.46.0-4.el9_4.noarch - Restart
NetworkManager: Restarting theNetworkManagerservice may resolve the issue:[root@localhost pcap]# systemctl restart NetworkManager - Verify the settings: After restarting, check if the changed settings were applied correctly:
[root@localhost pcap]# nmcli connection show BCM57414-IntNIC1-P1-25Gb | grep 802-3-ethernet.mtu 802-3-ethernet.mtu: 9000 [root@localhost pcap]# nmcli connection show BCM57414-IntNIC1-P2-25Gb | grep 802-3-ethernet.mtu 802-3-ethernet.mtu: 9000 - Bring the ports down and up to apply the new configuration:
[root@localhost pcap]# nmcli con down BCM57414-IntNIC1-P1-25Gb && nmcli con up BCM57414-IntNIC1-P1-25Gb Connection 'BCM57414-IntNIC1-P1-25Gb' successfully deactivated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/2) Connection successfully activated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/17) [root@localhost pcap]# nmcli con down BCM57414-IntNIC1-P2-25Gb && nmcli con up BCM57414-IntNIC1-P2-25Gb Connection 'BCM57414-IntNIC1-P2-25Gb' successfully deactivated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/3) Connection successfully activated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/18) - Test connectivity: In this example, the administrator changed the MTU setting, and ran a ping test to verify the connectivity and proper application of the MTU:
[root@localhost pcap]# ping 192.168.15.10 -s8972 -c4 PING 192.168.15.10 (192.168.15.10) 8972(9000) bytes of data. 8980 bytes from 192.168.15.10: icmp_seq=1 ttl=64 time=0.287 ms 8980 bytes from 192.168.15.10: icmp_seq=2 ttl=64 time=0.136 ms 8980 bytes from 192.168.15.10: icmp_seq=3 ttl=64 time=0.125 ms 8980 bytes from 192.168.15.10: icmp_seq=4 ttl=64 time=0.135 ms
For more detailed information about network configuration, see the official Rocky Linux documentation: Network Configuration - Documentation
Affected Products
Red Hat Enterprise Linux Version 7, Red Hat Enterprise Linux Version 9, Red Hat Enterprise Linux Version 8Article Properties
Article Number: 000284281
Article Type: Solution
Last Modified: 08 Nov 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.