Failure to Provision Device Using vPro-AMT Configure Client in Task Sequence

Summary: Resolving the failure of Tigerlake - H Chipset platforms to get provisioned while performing the vPro-AMT Configure Client task sequences. That refers the ACU configuration package 12.2.0.150 or 12.2.0.139. ...

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Symptoms

The failure of Tigerlake-H Chipset platforms to get provisioned while performing the vPro-AMT Configure Client task sequences. The error message states: Failed to configure this Intel(R) AMT device. Failed to generate the PKCS10 request using the Intel(R) AMT device. Error while generating PKCS10 certificate request. AMT Status code - The requested configuration is unsupported.

Cause

The provisioning failure on Tigerlake-H Chipset platforms is due to using the SCS and ACU configuration package versions less than 12.2.0.152. Older versions are not compatible with the required configuration.

Resolution

Upgrade the Intel SCS package to 12.2.0.152 to provision such computers and as per Intel, SCS 12.2.0.152 will not upgrade an existing installation of 12.2.0.150 and 12.2.0.139. The following procedure has to be followed to achieve Remote Provisioning.

  1. Upgrade the Dell Command | Integration Suite for System Center to 5.5.
    Dell Command
  2. Delete the vPro-AMT ACUConfig Package (ACU Config version 12.2.0.150 or 12.2.0.139) from Configuration Manager, System Center Config Mgr (SCCM).
    Dell vPro-AMT Development
  3. Delete all the vPro-AMT Task Sequences.
    vPro-AMT Tasks
  4. Launch the Registry Editor from the run command Windows + r.
    Run regedit
  5. Update the below Registry Value isClientDiscoverySetUp to 0.
    IsClientDiscoverySetUp
  6. Launch the Dell Command | Intel vPro out of band application in admin mode by right clicking Run as Administrator which would create the vPro-AMT ACUConfig Package (ACU Config Version 12.2.0.152) and vPro-AMT Discovery Client task sequence on configuration manager (SCCM).
  7. Launch the Local User and Groups from the Run command.
    Run lusrmgr.msc
  8. Select Groups and on the right side double-click Administrator group and remove RProAMTAdmins buy clicking Select, Remove, Apply, and OK.
  9. Launch the Active Directory Users and Computers on the domain controller by clicking Start, Server Manager, Tools, and Active Directory Users and Computers.
  10. Delete the folder RProAMtComputers. Select users and on the right side delete RproAdmin and RProAMTAdmins.
  11. Launch the Certificate Authority from the domain controller by clicking Start and then Certificate Authority, expand the certificates and select Certificate Templates. On the right side, find the certificate with the name RProConfigMgrAMTWebServerCertificate and delete it.
  12. Uninstall the previously installed SCS Package 12.2.0.150 or 12.2.0.139 from Program and Features.
  13. Update the below Registry Values and this will enable you to reperform the Remote Provisioning.
    1. Edit the RProApplyStatus value to 0. 
      RProApplyStatus
    2. Edit the below selected values to 0.
      Registery Editor
  14. Close and relaunch the Dell Command | Intel vPro out of band application in admin mode and reperform the Remote Provisioning by browsing the SCS Package 12.2.0.152.
    Dell Command vPro Remote Configuration Services Installation 9
  15. Once Remote Provisioning is successful, deploy the Discover and Configure task sequence to the client and the client provisioning should be successful.
    Discover and Configuration

Affected Products

OptiPlex, Tower, Latitude, Venue, Mobile Workstations
Article Properties
Article Number: 000188815
Article Type: Solution
Last Modified: 16 Jun 2025
Version:  4
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