VPLEX: El firmware de un director puede fallar debido a un error relacionado con la capa de caché

Summary: En este artículo, se aborda el error que se puede generar en un director de VPLEX y que provoca que el firmware del director se bloquee.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Hardware afectado por Dell:
VPLEX-Series
VPLEX-VS2
VPLEX-VS6
VPLEX-Local
VPLEX-Metro-FC and IP

Software afectado de Dell:
GeoSynchrony 6.0.x

Impacto:
El firmware del director se reiniciará; sin embargo, no debería haber ningún impacto en los hosts configurados para HA.  Los hosts perderán rutas al director cuando el firmware se bloquee y deberán recuperar las rutas cuando el firmware se reinicie de forma automática.

Problema:
Un director de VPLEX puede experimentar una bloqueo de firmware con el siguiente mensaje registrado:

Reason for the crash: /export/local1/jenkins/clone_D50.10/nsfw/snac/cch/cache.c:invalidatePageWithHashImpl/1321: NULL dv on inval page 0x3e3209 flags 0x4 table 15

Cause

Una lectura de varias páginas está pendiente en un director, y para una de las páginas (en específico no la última), estamos esperando el acceso a la página en la caché antes de poder comenzar. Ahora el enlace deja de funcionar y se activa, y aprendemos que el otro clúster continuó con I/O en el volumen en cuestión mientras el enlace estaba inactivo. Como parte de la limpieza de las I/O pendientes en el clúster de lectura, se produce un error de indexación y se accede al campo incorrecto en un arreglo, lo que provoca la falla de una comprobación de coherencia.

Resolution

Resolución:
Este problema se resolvió en GeoSynchrony 6.1.x y versiones posteriores

No hay una solución alternativa para este problema. La única solución a fin de evitar encontrar este problema de nuevo es actualizar VPLEX a la versión de código más reciente.

Affected Products

VPLEX Series, VPLEX VS2, VPLEX VS6
Article Properties
Article Number: 000196501
Article Type: Solution
Last Modified: 11 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.