Isilon: InsightIQ: Adding a Cluster Fils with Message: Error Getting Cluster Configuration. Please Try Again: List Index Out of Range

Summary: This KB article explains a specific failure in adding a OneFS cluster to InsightIQ.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The following "index is out of range" error message is seen in the web page when attempting to add a cluster to InsightIQ:

/var/log/insightiq.log 
2020-02-13 21:38:25,079 ERROR [insightiq.lib.cluster.config.config_monitor] Error in Config Monitor for <updating... 000e1e82eaf0d6ae7f5dd904a821e830163a>, not updating cluster info: list index out of range

Cause

InsightIQ is unable to process the Dedupe Job reports from the OneFS cluster it is trying to add.

Resolution

The only workaround is to delete all Dedupe job reports on the cluster.
Note:
This workaround removes your ability to see the Dedupe reports on past deduplicate jobs.  
 

# cp /ifs/.ifsvar/db/celog/events.db /ifs/data/Isilon_Support/events.db.bk

# sqlite3 /ifs/.ifsvar/db/celog/events.db "DELETE FROM events WHERE message LIKE '%dedupe%' AND event_id > 400100000 AND event_id < 400110000"

Affected Products

Isilon InsightIQ

Products

Isilon InsightIQ
Article Properties
Article Number: 000063201
Article Type: Solution
Last Modified: 20 Oct 2025
Version:  7
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