Avamar: MCS shutdown workflow stops responding while flushing ClientRegistryService

Summary: During Avamar shutdown, the process stopped responding while stopping the MCS.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

 MCS startup failed due to following the error:

Startup Failed: Closing all connections to database. Server already started on port: 7778 

Cause

The ClientRegistryService flushing stopped responding when MCS is being shut down. All services are flushed during MCS shutdown, starting with ClientRegistryService.

> 08/13-12:13:51.00900 [RMI TCP Connection(109)-10.241.180.21#904] com.avamar.asn.Node._stop
> FINE: Stopping the service container...
> 08/13-12:13:51.00902 [FlushCacheThread#1042] com.avamar.asn.service.ServiceContainerImpl$FlusherThread.run
> FINE: About to flush com.avamar.mc.cr.ClientRegistryService
> --
> 08/13-12:13:51.00993 [FlushCacheThread#1042] com.avamar.asn.service.ServiceContainerImpl$FlusherThread.run
> FINE: Done flushing com.avamar.mc.cr.ClientRegistryService in 91 ms
> ...
> ...
> FINE: About to flush com.avamar.mc.pdm.ProxyDeploymentManagerService
> 08/13-12:13:52.00031 [FlushCacheThread#1092] com.avamar.asn.service.ServiceContainerImpl$FlusherThread.run
> FINE: Done flushing com.avamar.mc.pdm.ProxyDeploymentManagerService in 0 ms

This log shows only ClientRegistryService is being flushing without completing.
 

> 08/13-00:06:29.00971 [RMI TCP Connection(3663)-10.241.180.21#68659] com.avamar.asn.Node._stop
> FINE: Stopping the service container...
> 08/13-00:06:29.00972 [FlushCacheThread#68734] com.avamar.asn.service.ServiceContainerImpl$FlusherThread.run
> FINE: About to flush com.avamar.mc.cr.ClientRegistryService 

The main job of flushing ClientRegistryService is to update all clients from cache to mcdb.

> 08/13-00:06:29.00972 [FlushCacheThread#68734] com.avamar.mc.cr.ClientStore.saveAll
> FINE: Start saving clients in ClientStore...
> 08/13-00:06:29.00972 [FlushCacheThread#68734] com.avamar.mc.cr.ClientStore.saveAll
> FINE: Flushing client f6a0975c4854536da1089c6800dc1212b2257a9a due to server shutdown,

Resolution

Find the PID of "java.*mcserver"

 ps -eaf | grep "java.*mcserver"

Manually stop the MCS process. 

pkill -9 <PID of "java.*mcserver">


If this occurred during startup, restart with:

dpnctl start


It is possible but not likely that the MCS flushing leaves the MCS in an inconsistent state. To restore the previous flush:

dpnctl start --force_mcs_restore


To ensure all is well and services have been brought up successfully, can check status with.

dpnctl status
Identity added: /home/admin/.ssh/admin_key (/home/admin/.ssh/admin_key)
dpnctl: INFO: gsan status: up
dpnctl: INFO: MCS status: up.
dpnctl: INFO: emt status: up.
dpnctl: INFO: Backup scheduler status: up.
dpnctl: INFO: Maintenance windows scheduler status: enabled.
dpnctl: INFO: Unattended startup status: enabled.
dpnctl: INFO: avinstaller status: up.
dpnctl: INFO: ConnectEMC status: up.
dpnctl: INFO: ddrmaint-service status: up.

Affected Products

Avamar

Products

Avamar, Avamar Server, PowerProtect Data Protection Software, Integrated Data Protection Appliance Family, Integrated Data Protection Appliance Software
Article Properties
Article Number: 000079437
Article Type: Solution
Last Modified: 28 Nov 2025
Version:  4
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