SRM: V hlášeních chybí informace o verzi DPA

Summary: Hlášení SRM nezobrazují nebo neaktualizují informace o verzi DPA.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

V zprávě SRM DPA chybí informace o verzi DPA.

Problém byl zjištěn u softwaru SRM verze 4.6.x a 4.7.0.x.

Cause

Data se shromažďují správně, ale filtry na kolektoru odlupují informace o verzi.

Resolution

Náhradním řešením je upravit dva konfigurační soubory v hostiteli kolektoru DPA.

  1. U souboru /opt/APG/Collecting/Variable-Handling-Filter/emc-dpa/conf/backup-restore-aggregation-aggregation-handler.xml přidejte ke každé části souboru konfigurace , jak je znázorněno:
    
    
            (name=='Files' & datagrp=='RESTORE-CLIENT-CONFIG')
            datagrp
            bkptech
            bkpservr
            mediasvr
            device
            state
            name
            
                
                group
                
            
            
                Files
                DPA-Collector
                1.0
                nb
                
                
                
            

 

Nezapomeňte ke každé části přidat řádek < název ="bkprev" />.

 

  1. Pro /opt/APG/Collecting/Cross-Referencing-Filter/emc-dpa/conf/dpa-server-client-cross-referenceing-filter.xml změňte filtr na (datagrp=='BACKUP-CLIENT-CONFIG' &name=''. RemoveMeZero') | datagrp=='BACKUP-CLIENT-CONFIG' &> (name=='Availability' | name='Files' | name=='Size' | name=='Propustnost' | name='Duration' | name='Status').

 

Viz změna níže:


    true
    com.watch4net.apg.v2.collector.plugins.crossreferencingfilter.data.mem.MemoryHashDataAccessor
    
        (datagrp=='BACKUP-CLIENT-CONFIG' & name=='RemoveMeZero') | datagrp=='BACKUP-CLIENT-CONFIG' & (name=='Availability' | name=='Files' | name=='Size' | name=='Throughput' | name=='Duration' | name=='Status')
        bkpservr
        true
        0
        bkprev
    
 
  1. Restartujte kolektor a po zjištění by se měla data nacházet.

Rozlišení:
V nadcházející verzi softwaru SRM je naplánována trvalá oprava. Dokud nebude tato oprava dostupná, použijte toto náhradní řešení.
Article Properties
Article Number: 000198308
Article Type: Solution
Last Modified: 13 May 2026
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.