PowerStore: Upgrade Package Upload Fails Due to Maximum Number of Packages Limit. Error Code: 0xE04030010049
Summary: Health check upgrade package failed to upload with an error reported in PowerStore Manager: Upload failed: Maximum number of packages Please delete a package and then upload the package again. (0xE04030010049) ...
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Symptoms
An attempt to upload a package in the PowerStore Manager user interface fails with error message:

Figure 1: Package upload fails with message "Maximum number of packages."
Upload failed: Maximum number of packages. Please delete a package and then upload the package again. (0xE04030010049)

Figure 1: Package upload fails with message "Maximum number of packages."
Cause
A new check (Max_Upgrade_Packages_Per_Appliance) was introduced in PowerStoreOS v3. Only packages with status Installed are excluded from the limit check. The maximum number of packages limit is triggered if there are 10 or more package entries not in an Installed state.
Resolution
Workaround
A support engagement is required in order to resolve this issue. Contact Dell Technical Support or your Authorized Service Representative, and quote this Dell Knowledge Base article ID.Fix
This issue is resolved in PowerStoreOS version 3.6Affected Products
PowerStoreArticle Properties
Article Number: 000215493
Article Type: Solution
Last Modified: 12 Oct 2023
Version: 7
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