Connectrix: Cisco MDS series error protocol identification string lack carriage return
Summary: Error on switch %DAEMON-3-SYSTEM_MSG: error: protocol identification string lack carriage return
Symptoms
These errors are seen:
# show logging log 2024 Nov 5 03:05:01 PSTIEBN5003 %DAEMON-3-SYSTEM_MSG: error: protocol identification string lack carriage return - dcos_sshd[20871] 2024 Nov 5 03:05:03 PSTIEBN5003 %DAEMON-3-SYSTEM_MSG: error: protocol identification string lack carriage return - dcos_sshd[7528] 2024 Nov 5 03:05:04 PSTIEBN5003 %DAEMON-3-SYSTEM_MSG: error: protocol identification string lack carriage return - dcos_sshd[7572]
Cause
The issue may start after the upgrade of MDS or Nexus switches managed by DCNM Version 11.3 or later.
The switch is encountering the issue CSCvv24160.
A Cisco account is required to view the following link: https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvv24160
Resolution
The log messages themselves are harmless but they may end up filling up the logs. Hence, changing the logging level on the switch would be the preferred option until DCNM can be upgraded to the fixed version.
Workaround:
1. Do the following configurations on the switch: logging level daemon 2
2. Increase the DCNM polling interval to the maximum (15 minutes) to help reduce the number of log entries.
To implement this, go to Web UI Administration -> Server Properties page. Locate the propertycdp.pollingInterval, and increase the value to a larger number (default 300 s), like 600 s or 900 s.
Fix: Upgrade to NDFC 12.x
Additional Information
Lowering the logging level of a daemon from level 3 (Error) to level 2 (Critical), results in fewer log messages being recorded. Only messages that are classified as Critical or more severe is logged. Here is a quick breakdown of what this means:
Level 3 (Error): Logs error conditions, which are issues that might still allow the system to continue running but indicate a problem that needs attention
Level 2 (Critical): Logs critical conditions, which are more severe issues that could cause significant problems or system failures
Setting the logging to "level 2" filters out less severe error messages and only captures critical issues. This reduces the volume of logs and focuses on the most serious problems.