Avamar: Troubleshooting Garbage Collection (GC) Failures (Resolution Path)

Summary: This is a resolution path article for troubleshooting Garbage Collection (GC) Failures.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Garbage Collection (GC) failures are seen in the Avamar Administrator Console, and reported in the outputs of the status.dpn and dumpmaintlogs commands when run on the Avamar Utility Node.
 
These failure messages include, but not limited to:
  • MSG_ERR_BACKUPSINPROGRESS
  • MSS_ERR_DISKFULL
  • MSG_ERR_TIMEOUT
  • MSG_ERR_NOPARITY
  • MSG_ERR_MISC
 

The event code for a Garbage Collection Failure is 4202.

Cause

Garbage Collection can fail for various reasons. 

There is typically an error message associated with the failure that indicates why the Garbage Collection failed.

This resolution path walks the reader through how to troubleshoot the Garbage Collection failures based on the associated error reported. 

Resolution

Validate that each troubleshooting step below is true for your environment. Each step provides instructions or a link to a document, to eliminate possible causes and take corrective action as necessary.

1. Log in to the Avamar Utility Node as admin and load the admin keys. See Avamar: How to Log in to an Avamar Server and Load Various Keys for instructions on loading keys.

The rest of this KB article assumes that the admin keys are loaded.

2. Collect all the output from commands listed in Avamar: How to gather the information to troubleshoot capacity issues.  

3. High checkpoint overhead can cause the Garbage Collection (GC) to fail if the Operating System (OS) capacity is too high. By default, GC fails with MSG_ERR_DISKFULL if the OS capacity rises above 89%. Verify that there are no capacity issues on the grid using Avamar: Operating System (OS) Capacity (Resolution Path).

4. A type of timing issue (Avamar v7+) can be seen with MSG_ERR_TRYAGAINLATER due to certain Avamar tasks that cannot allow GC to run simultaneously. See Avamar: Garbage collection failing with MSG_ERR_TRYAGAINLATER.

5. If garbage collection fails with MSG_ERR_GARBAGECOLLECT, see Avamar: Garbage Collection fails with the error MSG_ERR_GARBAGECOLLECT.

6. If garbage collection fails with MSG_ERR_BADTIMESYNC, see Avamar: Failed garbage collection with error MSG_ERR_BADTIMESYNC

7. If garbage collection fails with MSG_ERR_DUPLICATE, see Avamar: Garbage collection fails with MSG_ERR_DUPLICATE

 

Reference:

For other GC error messages including MSG_ERR_TIMEOUT, MSG_ERR_DDR_ERROR, MSG_ERR_NOPARITY (or anything not mentioned in this article), contact the Dell Technologies Avamar Support Team

The rest of the error messages have internal-only solutions.

If any other Non-GC-error capacity issues are found, see Avamar: Capacity Troubleshooting, Issues, and Questions - All Capacity (Resolution Path)

Additional Information

 

Affected Products

Avamar, Avamar Server
Article Properties
Article Number: 000037107
Article Type: Solution
Last Modified: 08 Jul 2025
Version:  13
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