PowerEdge: Linux server is unable to boot with multiple paths configured to the boot device (boot from SAN)

Summary: There might be many reasons for a boot from SAN to fail and not following the recommendations of our Host Configuration Guide is most often the reason for the issue. But for this particular KB, the setup had been made as per our recommendations and nevertheless the boot was failing. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A Linux server running on Cisco UCS C220 M5SX is unable to boot up with two HBAs configured to four FAs on a VMAX3 array. The Cisco Integrated Management Controller (CIMC) was upgraded to firmware version 4.1(3f) after which the server could not boot. Prior to the firmware upgrade the server could boot successfully.

Investigations have determined that if a single HBA is configured to access a single FA the server boots without any issues.

When a second path is configured it will not boot.

Cause

The issue was caused here by an incompatibility between the Cisco Integrated Management Controller (version 4.1.3f) and the Emulex HBA firmware (v12.8.351.47).

Resolution

Upgrading CIMC to version 4.2.2a and Emulex firmware to v12.8.542.37 resolved the boot issue

You might encounter other incompatibility issues.

This KB aims to inform support staff of potential issues, especially after upgrading either of these two components.

.

Affected Products

Storage, PowerEdge XR2, Poweredge C4140, PowerEdge C6400, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6600, PowerEdge C6615, PowerEdge C6620, PowerEdge FC640, PowerEdge HS5610, PowerEdge HS5620, PowerEdge M640 , PowerEdge M640 (for PE VRTX), PowerEdge MX5016s, PowerEdge MX7000, PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R230, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R330, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R430, PowerEdge R440, PowerEdge R450, PowerEdge R470, PowerEdge R530, PowerEdge R530xd, PowerEdge R540, PowerEdge R550, PowerEdge R630, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R730, PowerEdge R730xd, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R7715, PowerEdge R7725, PowerEdge R830, PowerEdge R840, PowerEdge R860, PowerEdge R930, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T40, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640, PowerEdge XR11, PowerEdge XR12, PowerEdge XR4000r, PowerEdge XR4000w, PowerEdge XR4000z, PowerEdge XR4510c, PowerEdge XR4520c, PowerEdge XR5610, PowerEdge XR7620, PowerEdge XR8000r, PowerEdge XR8610t, PowerEdge XR8620t ...
Article Properties
Article Number: 000203622
Article Type: Solution
Last Modified: 04 Mar 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.