PowerPath Management Appliance: ESXi 8.0 U1 hosts are showing as Disconnected in PPMA GUI and running rpowermt commands return: "Error while extracting JWT token"
Summary: ESXi 8.0 U1 hosts are showing as Disconnected in PPMA GUI and running rpowermt commands return: "Error while extracting JWT token"
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Symptoms
From datacollector logs, we can see the error "ESXi failed to issue the bearer token with an error for host:1xx.xx.xx.12"
Cause
The vCenter user "powerpath" did not have Global permission intact.
Resolution
Add the user with "Global Permission" which would allow the client (PPMA) to communicate with the ESXi hosts seamlessly.
Goto, Administration > Global Permission > Click on 'Add' from the right pane > Add the required role for powerpath user and check the "Propagate to children" box.
Re-add the vCenter in PPMA and ESXi hosts show as Connected and should be able to run rpowermt commands without throwing an error.
Goto, Administration > Global Permission > Click on 'Add' from the right pane > Add the required role for powerpath user and check the "Propagate to children" box.
Re-add the vCenter in PPMA and ESXi hosts show as Connected and should be able to run rpowermt commands without throwing an error.
Additional Information
More details on the user level is documented in the Installation and Configuration Guide:
https://www.dell.com/support/home/en-us/product-support/product/powerpath-management-appliance/docs
https://www.dell.com/support/home/en-us/product-support/product/powerpath-management-appliance/docs
Affected Products
PowerPath Management ApplianceArticle Properties
Article Number: 000218637
Article Type: Solution
Last Modified: 13 Nov 2023
Version: 2
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