NMC 19.7.x: the NMC returns "Internal Server Error"

Resumen: NMC Admin user interface on pops up "Internal Server Error. Please see console log for more information" and JAVA Console Log has a java.lang.NullPointerException.

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Síntomas

  • After a NetWorker upgrade to 19.7.1.0 on Windows server, the following error appears in the NetWorker Management Console (NMC): "Internal Server Error. Please refer to console log for more information
  • The Protection -> Policies lists no policies.
  • The Protection -> Groups and the Protection -> Clients are listed with red circles with White exclamations (Emergency icon). Hovering over the Emergency icon the text pop up is

"Group <Group_name> need to be associated with Policy and Workflow.
For steps on how to do it, refer admin guide."

"Client <Client_name> need to be associated with protected Group.
For steps on how to do it, refer admin guide."

  • The NetWorker server is functioning as expected; command-line options for managing the server, show no issue.
  • When policies are running nsrwatch correctly shows session details.
  • The NMC allows configuring most of the other resources. Policies are unconfigurable from the NMC.
  1. Launching the NetWorker Runtime Environment (NRE) JAVA console with the command javaws.exe -viewer, under the Advanced tab mark

enable tracing
enable logging
show console

  1. When relaunching the NMC GUI, there is a java.lang.NullPointerException when the pop-up for the Internal Server Error is encountered.

Causa

This problem results from a known product defect.

Resolución

This issue was fixed as of version 19.10.0.0 and later.
 

WORKAROUND:

Install and use the NWUI (NetWorker Management Web UI).

Productos afectados

NetWorker

Productos

NetWorker Family, NetWorker Series
Propiedades del artículo
Número del artículo: 000214915
Tipo de artículo: Solution
Última modificación: 30 oct 2024
Versión:  3
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