Avamar: Hyper-V backups fail with Access Denied errors
Resumen: Avamar - Hyper-V backups fail with Access Denied errors.
Síntomas
In this case scenario, we experience Hyper-V backup failures and the backup logs shows the "AccessDenied" error messages as per the example below:
From Hyper-V Plugin log: ================ avhypervvss Info <0000>: Error in connecting with the namespace: Exception 'GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))' avhypervvss Info <0000>: Failed to get the VM info: Excpetion 'GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))' avhypervvss Info <0000>: QueryVmsBasic : QueryVmsBasic : GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) avhypervvss Info <0000>: QueryVmsFull : QueryVmsBasic : QueryVmsBasic : GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) avhypervvss Info <0000>: GetClusterVMs : QueryVmsFull : QueryVmsBasic : QueryVmsBasic : GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) avhypervvss Info <0000>: Exception in GetClusterVMs GetClusterVMs : QueryVmsFull : QueryVmsBasic : QueryVmsBasic : GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)). avhypervvss Error <41753>: Unable to get the clustered VMs for backup. avhypervvss Error <41731>: Failed to collect the list of local VMs on this host avhypervvss Error <41581>: Failed to backup targets. Unable to expand targets. avhypervvss Error <41662>: Failed to validate and expand the targets. avhypervvss Error <41659>: Backup did not complete successfully From cluster service log: ================ winclustersvc DEBUG<0000>: ===> QueryVmsFull winclustersvc INFO<0000>: Get the basic info for the target VMs winclustersvc INFO<0000>: Start getting the basic of the VMs winclustersvc DEBUG<0000>: Connect with namespace '\\xxxxxxxx\root\virtualization\v2' winclustersvc ERROR<0000>: Error in connecting with the namespace: Exception 'GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))' winclustersvc ERROR<0000>: Failed to get the VM info: Excpetion 'GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))' winclustersvc ERROR<0000>: QueryVmsBasic : QueryVmsBasic : GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) winclustersvc ERROR<0000>: QueryVmsFull : QueryVmsBasic : QueryVmsBasic : GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) winclustersvc ERROR<0000>: GetClusterVMs : QueryVmsFull : QueryVmsBasic : QueryVmsBasic : GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) winclustersvc ERROR<0000>: Exception in GetClusterVMs GetClusterVMs : QueryVmsFull : QueryVmsBasic : QueryVmsBasic : GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)).
Causa
These types of errors are self-explanatory. These errors mean that the user account for the Avamar services (local agent and cluster agent) does not have sufficient permissions to run the Windows Management Instrumentation (WMI) queries.
To address this issue, grant the correct permissions to the user account being used to run the Avamar client services.
Resolución
To correct the backup user permissions, follow the KB article below:
Avamar: Hyper V plug-in - How to manually create and configure the user account with and without using Domain Admin Privileges.
Información adicional
This is also mentioned in more detail in the "Dell Avamar for Hyper-V User Guide." See the link to the guide for version 19.10 or for any other version see the Avamar support page.