NetWorker: Jak odebrat nástroj NetWorker, když se nezdaří odinstalace nebo upgrade (Windows)

Resumen: NetWorker: Postup odebrání po selhání odinstalace v hostiteli Windows

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

  • Serverové balíčky NetWorker Server, Storage Node, Client a/nebo Management Console (NMC) se instalují do operačního systému Windows.  
  • Instalace, odinstalace nebo upgrade NetWorker se nezdařil.

 

Causa

Existují různé problémy na úrovni operačního systému, které mohou způsobit selhání odinstalace/upgradu. Protokol instalace/nebo odinstalace je propojen v průvodci instalací. Neúspěšná instalace nebo odinstalace vrátí kód chyby spuštění MSI: https://learn.microsoft.com/windows/win32/msi/error-code image.png

Tento článek znalostní databáze se zaměřuje na akce, které lze provést pro čisté odebrání nástroje NetWorker, aby jej bylo možné znovu nainstalovat. Provádění akcí uvedených v tomto článku znalostní databáze nemění ani neodstraňuje žádné konfigurační nebo databázové soubory nástroje NetWorker. Procesy, které jsou do toho zapojeny, pouze pomáhají vyčistit systémové servisní soubory a umožňují úspěšné dokončení odinstalace.
 

Resolución

Požadavky

  • Pokud je systém NetWorker virtuálním počítačem, před provedením níže uvedených kroků se doporučuje vytvořit snapshot systému. Po dokončení procesu lze snapshot odebrat.
  • Pokud se jedná o server NetWorker, shromážděte podrobnosti o spouštěcí sadě uložení z e-mailových zpráv zásad ochrany serveru (pokud jsou nakonfigurovány). Značka ".. Ke shromáždění podrobností o spouštěcí sadě a zařízení lze také použít protokoly \nsr\policy\logs\Server Protection\Server db backup\Server db backup_jobid_logs". Není to nutné, pokud je systém klientem NetWorker, samostatným serverem NetWorker Management Console (NMC), samostatným serverem NetWorker Web User Interface (NWUI) nebo samostatným uzlem úložiště NetWorker.
POZNÁMKA: Podpora NetWorker nesmí provádět akce, které zahrnují odebrání balíčků nebo změny systému. Lze zapojit podporu NetWorker; Všechny akce, které vyžadují změny instalačních balíčků nebo registrů systému, však musí provést správce systému. Pokud potřebujete pomoc s tímto procesem, obraťte se na správce systému Windows. Služby Dell Professional Services lze využít také k instalacím a procesům upgradu. Chcete-li využít profesionální služby, obraťte se na obchodního zástupce společnosti Dell nebo místního obchodního zástupce.


Odebrání z příkazového řádku:

1. Zastavte všechny platné služby NetWorker, NetWorker Management Console a NetWorker Web User Interface:

net stop nsrexecd /y

net stop nwui /y

 
POZNÁMKA: Zastavením služby nsrexecd (klient) by se měly zastavit všechny závislé služby: NMC (gstd), server (nsrd) a služby uzlů úložiště. Služby NWUI musí být zastaveny samostatně. Zkontrolujte, zda byly služby zastaveny pomocí příkazu tasklist nebo v okně Microsoft services.msc.

NetWorker Management Console:
 
  • Databázová služba EMC GST.
  • Služba EMC GST.
  • Obsluha depeší EMC GST
  • Webové služby EMC GST.
Server/klient/uzel úložiště NetWorker:
  • Server NetWorker pro zálohování a obnovení.
  • Adaptér fronty zpráv NetWorker.
  • Služba NetWorker Remote Exec Service
  • Služba NetWorker Snapshot Management Service
Server webového uživatelského rozhraní NetWorker (NWUI):
  • Server webového uživatelského rozhraní NetWorker Management.
  • Databáze webového uživatelského rozhraní NetWorker.
2. Podle nainstalované verze nástroje NetWorker zadejte následující příkaz.
Produkt wmic, kde "Vendor = 'Dell EMC'" získá název, IdentifyingNumber, PackageName
 
Příklad:
C:\Users\Administrator> wmic
wmic:root\cli>product where "Vendor = 'Dell EMC'" get name, IdentifyingNumber, PackageName
IdentifyingNumber                       Name                                PackageName
{A901A570-8BC9-462D-B07F-3396F7387555}  NetWorker Extended Client           NwExtClientMsi.msi
{C5E4AD90-15E2-4386-B106-3778ADC2A861}  NetWorker                           NwServerMsi.msi
{D9289E55-33F7-4ECE-BD1E-CFF259D17C45}  NetWorker Authentication Service    Authc.msi
{6A854AE6-C689-424A-8B96-85B032C151D4}  NetWorker                           NwClientMsi.msi
{503C3A3A-B164-4158-9007-6F8B2DC79B5D}  Config Checker                      CfgChkMsi.msi
{22E4288C-3019-4AF0-B2FF-21A254A68FE4}  NetWorker Management Console        NMC.msi
{0CDAFA1F-A2CD-4ADD-AAE9-77085F08F389}  NetWorker                           NwStorageNodeMsi.msi
{C368557F-33E0-402C-9BAB-645B5878CAE8}  NetWorker Management Web UI Server  mcui.msi
 
POZNÁMKA: Pokud nejsou v seznamu uvedeny žádné balíčky, přejděte ke kroku 5.

3. Pomocí následujícího příkazu odinstalujte jednotlivé moduly zvlášť. V klauzuli where použijte místo name hodnotu IdentifyingNumber, protože máme více modulů se stejným názvem "NetWorker". Doporučuje se odebrat komponenty, jako jsou balíčky NMC a NWUI, poté balíčky server/authc a nakonec klientský balíček. 
wmic product, kde "IdentifyingNumber = '{IdentifyingNumber}'" volá uninstall

Příklad:
wmic:root\cli>product where "IdentifyingNumber = '{A901A570-8BC9-462D-B07F-3396F7387555}'" call uninstall
Execute (\\WINSRVR2K22\ROOT\CIMV2:Win32_Product.IdentifyingNumber="{A901A570-8BC9-462D-B07F-3396F7387555}",Name="NetWorker Extended Client",Version="19.6.0.3")->Uninstall() (Y/N/?)? Y
Method execution successful.
Out Parameters:
instance of __PARAMETERS
{
        ReturnValue = 0;
};
POZNÁMKA: Pokud proces nebyl zastaven, může se zobrazit kód společnosti Microsoft 1603 "Během instalace došlo k závažné chybě".
 
4. Ověřte, že byly odebrány všechny balíčky NetWorker:
Produkt wmic, kde "Vendor = 'Dell EMC'" získá název, IdentifyingNumber, PackageName
 
5. Pokud je k dispozici příslušná služba, odeberte ji pomocí příkazu sc . Ujistěte se, že jsou všechny relace MMC  zavřené.
  • Pomocí dotazu sc se můžete dotazovat na všechny neodebrané služby NetWorker.
sc query state=all | findstr EMC
sc query state=all | findstr NetWorker
  • Pomocí příkazu sc delete odeberte všechny služby vrácené dotazem sc. Je možné použít některý z následujících příkazů:
    • sc delete "DISPLAY_NAME"
    • sc delete "SERVICE_NAME"
C:\Users\Administrator.EMCLAB>sc delete "NetWorker WebUI Database"
[SC] DeleteService SUCCESS

C:\Users\Administrator.EMCLAB>sc delete "EMCGSTWebServer"
[SC] DeleteService SUCCESS
POZNÁMKA: Server NWUI a databáze NMC a služby SNMP se nemusí odinstalovat, pokud je pro odstranění sc použit DISPLAY_NAME služby. Místo toho použijte SERVICE_NAME.
C:\Users\Administrator.EMCLAB>sc delete gstd
[SC] DeleteService SUCCESS

C:\Users\Administrator.EMCLAB>sc delete gstsnmptrapd
[SC] DeleteService SUCCESS

C:\Users\Administrator.EMCLAB>sc delete nwui
[SC] DeleteService SUCCESS

6. Ověřte, že všechny příslušné služby uvedené v kroku 1 byly odebrány z konzoly Services.msc.

7. Po odebrání všech služeb souvisejících s nástrojem NetWorker spusťte znovu průvodce instalací a výběrem možnosti "Remove" (Odebrat) by měla být instalace NetWorker úspěšně odebrána.
image.png
POZNÁMKA: Tím se neodstraní žádné databáze serveru NetWorker/NMC ani konfigurační soubory. Pokud se balíček stále nedaří odinstalovat. Je nutné odebrat registry systému Windows týkající se předchozích instalačních balíčků NetWorker. Pokyny naleznete v dodatečném informačním poli.
 
8. Nainstalujte nástroj NetWorker znovu přes stávající cestu k souboru. Další požadavky a podrobnosti k instalaci nástroje NetWorker naleznete v průvodci instalací nástroje NetWorker, který je k dispozici prostřednictvím: https://www.dell.com/support/home/product-support/product/networker/docs

 

Nástroj pro instalaci a odinstalaci programů společnosti Microsoft:

Pokud jste provedli výše uvedené kroky a instalace stále selhává, stáhněte si nástroj Microsoft Program Install and Install:

Microsoft Link: https://support.microsoft.com/help/17588/windows-fix-problems-that-block-programs-being-installed-or-removed image.png
Název balíčku: MicrosoftProgram_Install_and_Uninstall.meta.diagcab.
Značka: Opraveny problémy, které blokují instalaci nebo odebrání programů. 

Kroky:
1. Spusťte balíček MicrosoftProgram_Install_and_Uninstall.meta.diagcab.
2. Klikněte na možnost Opravit problémy s instalací.
     V seznamu zobrazených aplikací byste měli být schopni najít balíček NetWorker.

POZNÁMKA: Pokud balíček NetWorker není uveden v seznamu, vyberte možnost Not Listed, otevřete protokol neúspěšné instalace, vyhledejte neúspěšný balíček a shromážděte jeho název, například: {00CA8CFF-77E7-4DD1-8144-B93AF56F1A91}.

3. Vyberte balíček NetWorker a klikněte na tlačítko Opravit.
4. Po úspěšném provedení spusťte nástroj a zkontrolujte, zda problém přetrvává.
5. Nyní můžete pokračovat v instalaci balíčku.

 

Información adicional

Pokud možnosti uvedené v tomto článku znalostní databáze problém nevyřeší, poslední možností je ruční vymazání systémových registrů položek NetWorker.

Chcete-li odebrat registry NetWorker, otevřete soubor regedit.msc. Před provedením jakýchkoli změn v systémových registrech vytvořte kopii celého registru kliknutím na možnost Exportovat soubory> a uložte registr do umístění podle vlastního výběru. Poté klikněte na možnost Edit-Find>, zadejte NetWorker a poté prohledejte registr. Pomocí klávesy F3 na klávesnici můžete použít příkaz "hledat další". Pomocí tohoto procesu můžete projít registr a odstranit vše, co odkazuje na instalační balíček nebo službu NetWorker .msi. Není nutné odstraňovat žádná pravidla brány firewall, registry související s cestami ke složkám ani výsledky prostředí NetWorker Runtime Environment (NRE). Po dokončení restartování systému zkontrolujte, zda se v oknech "Programy a funkce" a "Služby" nenacházejí položky NetWorker. Pokud se služby nebo balíčky NetWorker nezobrazí, můžete se pokusit přeinstalovat NetWorker přes dříve použitou instalační cestu.

Productos afectados

NetWorker

Productos

NetWorker, NetWorker Series
Propiedades del artículo
Número del artículo: 000027143
Tipo de artículo: Solution
Última modificación: 06 nov 2025
Versión:  6
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.