Dell Unity: Una situación de datos no disponibles puede ocurrir si un SP se reinicia después de reemplazar una unidad del sistema debido a una condición de EOL

Resumen: Problema: Si se utilizan unidades del sistema para crear un Dynamic Pool y una unidad del sistema llega al final del ciclo de vida (EOL), la unidad se reemplaza físicamente por una unidad en buen estado; existe una condición por la cual un solo reinicio del SP puede dejar fuera de línea al Dynamic Pool, lo que provoca que los datos no estén disponibles. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Condiciones que deben existir antes de que se produzca un evento de pool de DU fuera de línea:

  1. La unidad del sistema se informa a sí misma como en final del ciclo de vida (EOL).
  2. El sistema ejecuta una versión de Unity OE 4.2.x.
  3. Luego, la unidad en EOL se reemplaza con una unidad nueva mediante la acción del usuario.
  4. Se reinicia un único SP, lo que provoca que el pool esté fuera de línea y que se produzca una situación de DU.

Este problema ocurre solo con los Dynamic Pools que se basan en unidades del sistema (ranuras de unidad del DPE 0, 1, 2 y 3), con las versiones 4.2.0 y 4.2.1 de Unity OE, en las que una unidad del sistema se informó como en final del ciclo de vida (EOL). Si la unidad se reemplaza físicamente por una unidad en buen estado, existe una condición por la cual el reinicio de un único SP puede dejar fuera de línea el Dynamic Pool, lo que provoca que los datos no estén disponibles.

La condición de datos no disponibles (DU) solo se producirá si uno de los SP se reinicia después de que la unidad en EOL se haya reemplazado físicamente por una unidad nueva.

Si después del reinicio de un único SP se produce una situación de DU en la que los recursos no están disponibles debido a que se informa que un pool está fuera de línea, un reinicio inmediato del SP alternativo que aún no se ha reiniciado resolverá la situación de DU y restaurará el pool a un estado en línea, sin riesgos adicionales de DU.

Varias alertas de advertencia, estado del sistema degradado para unidad en EOL:

Warning  14:60515  System unity550f has experienced one or more problems that have left it in a degraded state.
Warning  14:6027c  DPE Disk 1 is reaching the end of its service life and needs to be replaced.
Warning  14:60340  Storage pool Dynamic1 has 1 drive(s) predicted to exceed end-of-life thresholds within 0 day(s)...

Unisphere o UEMCLI podrían mostrar lo siguiente para la unidad del sistema en EOL:

The system has started an automatic copy of data from this drive that is wearing out to a spare drive.
Nota: El mensaje anterior puede ser confuso. Si el arreglo no tiene unidades de repuesto disponibles, el mensaje en realidad significa que las extensiones de usuario en la unidad del sistema se están copiando en extensiones de repuesto dentro del Dynamic Pool. Esto no quiere decir que se evita la situación de DU.

Estado del sistema CRÍTICO y pool fuera de línea si se reinició un SP:

Critical  14:6032b  Storage pool Dynamic1 is offline.  The pool is offline. Contact your service provider.
Critical  14:60514  System unity550f has experienced one or more problems that have had a critical impact

 

Causa

Hay un problema en 4.2.0 y 4.2.1 con los Dynamic Pools integrados en las unidades del sistema, por el cual cuando una unidad del sistema se informa que comenzó con el final del ciclo de vida (EOL), y el sistema y la unidad del sistema afectada se reemplazan físicamente por una nueva; existe la posibilidad de que ocurra un evento de DU cuando se reinicia un solo SP. El problema se debe a que el pool conserva incorrectamente la marca de EOL en la unidad que se utilizó para reemplazar físicamente la unidad del sistema EOL, a pesar de que la UI y la UEMCLI informan que el sistema funciona con normalidad. El reinicio de un solo SP hace que el Dynamic Pool asociado quede fuera de línea, lo que provoca la pérdida de acceso a cualquier número de unidad lógica (LUN) u objeto de File System compilado en ese pool.

En la sección Resolución que figura a continuación, se describe cómo recuperarse de una situación de DU existente (reiniciar el SP alternativo) o cómo evitar que se produzca la situación de DU y eliminar la condición de DU a través de una serie de pasos preventivos.

 

Resolución

Situación 1: Pool fuera de línea, DU en curso (se han producido las condiciones 1-5)
Si se han dado todas las condiciones, como se indicó anteriormente, y está experimentando una pérdida de acceso a objetos creados desde Dynamic Pools (es decir, el pool está fuera de línea), puede recuperarse de la situación de DU reiniciando inmediatamente el SP alternativo que aún no se ha reiniciado. Esto restaura el acceso y ya no hay ningún riesgo adicional de DU; el problema se resuelve de forma permanente.

El procedimiento para reiniciar un procesador de almacenamiento se puede encontrar en el siguiente artículo de la base de conocimientos: Dell Unity: Cómo reiniciar un procesador de almacenamiento (corregible por el usuario) .

Comentarios de la situación 1:
Si tiene una unidad del sistema que coincide con una condición de EOL, reemplazó la unidad en EOL y ahora experimenta una situación de DU después de reiniciar un SP, verá alertas o un mensaje de pool que dice “The pool is offline” para indicar que está fuera de línea. Puede restaurar el acceso y volver a poner el pool afectado en línea reiniciando inmediatamente el SP opuesto, es decir, el SP que aún no se ha reiniciado. Esto elimina el atributo de EOL persistente del Dynamic Pool y permite que el pool vuelva a estar en línea. Lamentablemente, si la situación de DU se produce durante una actualización de NDU, cuando el primer SP se reinicia para la actualización, el pool quedará fuera de línea, pero volverá al estado en línea después de que el segundo SP se haya reiniciado para la actividad de la actualización.

Resolución del cliente para la situación 1:

  1. Reinicie el SP alternativo que aún no se ha reiniciado o, en el caso de una NDU (actualización no disruptiva), permita que la NDU se complete.

Situación 2: Prevenir DU (solo se han producido las condiciones 1-4)
Si solo existen las condiciones 1-4, los DU aún no han ocurrido, ya que no se ha realizado ningún reinicio de SP. Realice los siguientes pasos para ayudar a prevenir una posible situación de DU.

Resolución del cliente para la situación 2:

  1. Si tiene una unidad de repuesto del mismo tipo (por ejemplo, SAS Fash 2) y tamaño (el tamaño puede ser mayor, pero no menor), y tiene una ranura de unidad abierta en el arreglo, inserte la unidad de repuesto y esta se repondrá automáticamente en el pool y eliminará el posible problema de DU.
  2. Después de esperar entre 10 y 15 minutos, una alerta y un estado del sistema deben informar que está normal (System xxx is operating normally).
  3. En Pool properties > Drives (pool asociado con la unidad del sistema en EOL), debería ver que la unidad de repuesto ahora está en uso y reemplazó a la unidad en EOL.
  4. En este momento, no se requiere ninguna otra acción. Sin embargo, si no puede verificar adecuadamente que la unidad de repuesto reemplazó a la unidad del sistema en EOL en el pool, comuníquese con el proveedor de servicios para obtener ayuda y consulte el número de este artículo.
  5. Si no tiene una unidad de repuesto que se pueda agregar a cualquier ranura del arreglo, comuníquese con el proveedor de servicios, consulte este artículo de la base de conocimientos y no reinicie ningún SP. El proveedor puede realizar pasos no disruptivos que eliminen al sistema de cualquier posible DU relacionado con el problema descrito en este artículo.

 

Información adicional

Este problema se resolvió en la versión 4.3.0.1522077968 y posteriores, aunque, como se indicó anteriormente, si las condiciones 1-4 ya existen y no se han corregido, durante la actualización de NDU a 4.3, después de que se reinicie el primer SP para la actualización, Dynamic Pool quedará fuera de línea, lo que dará como resultado DU. Sin embargo, después de actualizar y reiniciar el segundo SP, el pool volverá a estar en línea y el evento de DU terminará.

Consulte las notas de la versión más recientes de la familia Dell Unity para obtener más información.

Comuníquese con el equipo de soporte técnico de Dell o con su representante autorizado de servicios y mencione el ID de este artículo de la base de conocimientos.

 

Productos afectados

Dell EMC Unity Family |Dell EMC Unity All Flash

Productos

Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity Family |Dell EMC Unity All Flash
Propiedades del artículo
Número del artículo: 000050324
Tipo de artículo: Solution
Última modificación: 03 dic 2025
Versión:  5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.