Windows Server: La operación de reparación de Dism falla con el error "No se pudieron encontrar los archivos de origen"

Resumen: A veces es necesario reparar los daños en el almacén de componentes en Windows con el comando "dism /online /cleanup-image /restorehealth". Este comando falla si no puede localizar los archivos de origen de los archivos dañados que encuentra en el almacén de componentes. Este problema se puede resolver utilizando una imagen de evaluación descargada de los medios del sistema operativo (SO) como fuente. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

La variable dism /online /cleanup-image /restorehealth El comando falla con el error "No se pudieron encontrar los archivos de origen".

El dism.log archivo (ubicado en C:\Windows\Logs\DISM\dism.log) contiene varias instancias de este error, acompañadas de un código de error 0x800F081F. Es posible que también haya otros códigos de error presentes en el archivo de registro.

Causa

Para realizar reparaciones de objetos dañados en el almacén de componentes, la herramienta de administración y mantenimiento de imágenes de implementación (DISM) necesita una fuente de archivos no dañados.

De manera predeterminada, utiliza Windows Update como fuente, pero esto no siempre se realiza correctamente.

Resolución

Para resolver el problema, proporcione una fuente de archivos válidos para que el comando los utilice cuando realice una reparación. Por lo general, una imagen de evaluación descargada recientemente de la versión de Windows instalada en el sistema afectado es una fuente confiable. Estas imágenes se pueden descargar desde el CentroEste hipervínculo lo redirige a un sitio web fuera de Dell Technologies. de evaluación de Microsoft.

Es posible utilizar los medios existentes del sistema operativo como fuente de archivo; sin embargo, es más probable que la imagen de la evaluación esté actualizada. Los archivos de origen que no están actualizados hacen que el comando devuelva el mismo error "No se pudieron encontrar los archivos de origen".

Para resolver el problema, realice los siguientes pasos:

  1. Busque la imagen de evaluación correspondiente del Centro de evaluación de Microsoft en el vínculo anterior. Seleccione ISO en el indicador Seleccione su experiencia y descargue el archivo ISO en el sistema afectado.
  2. En el Explorador de archivos, haga clic con el botón secundario en el archivo ISO y seleccione Montar. La imagen ahora aparece como una unidad de DVD, con su contenido navegable. Anote la letra de unidad que se le asignó.
  3. En un símbolo del sistema con privilegios elevados, ejecute dism /get-imageinfo /imagefile:X:\sources\install.wim (reemplace X con la letra de unidad del paso 2) para enumerar las imágenes incluidas en el archivo. Anote el número de índice que corresponde a la edición de Windows instalada.
  4. Ejecutar dism /online /cleanup-image /restorehealth /source:WIM:X:\sources\install.wim:# /limitaccess (reemplace X con la letra de unidad del paso 2 y # con el número de índice del paso 3) para realizar la reparación utilizando la imagen montada como origen. La reparación debería terminar sin errores.
  5. Una vez finalizada la reparación, haga clic con el botón secundario en la imagen montada en el explorador de archivos y seleccione Expulsar para desmontarla.

Si el comando sigue arrojando un error sobre archivos de origen faltantes, consulte Windows Server: Agregue una actualización acumulativa a una imagen de Windows sin conexión para obtener un procedimiento que puede ser útil.

Información adicional

Otra posible fuente es el WinSxS de un servidor operativo que ejecuta la misma versión de Windows. Para usar esta carpeta como origen de archivo, ejecute este comando y reemplace <server> con el nombre o la dirección IP del servidor de origen:

DISM.exe /Online /Cleanup-Image /RestoreHealth /Source:\\<server>\c$\winsxs /LimitAccess

Productos afectados

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022, Microsoft Windows Server 2025, Microsoft Windows 2012 Server, Microsoft Windows 2012 Server R2
Propiedades del artículo
Número del artículo: 000198179
Tipo de artículo: Solution
Última modificación: 23 may 2025
Versión:  6
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.