NetWorker: No se pudo obtener el índice de archivos debido al mensaje de error "No se puede realizar la búsqueda del índice de la ruta 'ruta'. La sesión de índice no es válida"

Resumen: El respaldo incremental falla con el siguiente error: "No se pudo obtener el índice de archivos debido a. La sesión del índice no es válida".

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

El respaldo completo se completa correctamente sin errores, mientras que el respaldo incremental no se completa y muestra el siguiente error:

174422:save: Step (5 of 6) for PID-13894010: Reading the save sets and writing to the target device.
100690:save:<path>: File index could not be obtained due to <Unable to do Index lookup of path 'path'. The Index session is invalid

Esto también podría incluir mensajes similares a los siguientes en los registros de políticas:

Saving in pool '<Pool_Name>'.
Server enabled for immediate mode
...
RPC Authentication: <Client> failed to obtain RPCSEC_GSS credentials: Authentication error; why = Server rejected credential. Could not get a session key for GSS authentication.  Perhaps this authentication method is not allowed/supported by both the local and remote machines.
Failed to create lgto_auth credential for RPCSEC_GSS: Could not get session key from <Client> for GSS authentication with <NWS>: Authentication error; why = Server rejected credential.
Unable to acquire the user credentials for direct save nsrmmd authentication: Could not get session key from <Client> for GSS authentication with <NWS>: Authentication error; why = Server rejected credential.
175297:save: Unable to set up the direct save with server '<NWS>': Could not get session key from <Client> for GSS authentication with <Client>: Authentication error; why = Server rejected credential.
98520:save: Falling back to agent-assisted indirect save

 

Causa

NetWorker solo respalda directorios cuyo nombre cambió con archivos y subcarpetas sin cambios cuando se enumeran explícitamente los nombres de directorio en el atributo de saveset del recurso de cliente y si el directorio con cambio de nombre de respaldo está habilitado. 

Por ejemplo, si el campo de saveset contiene E:\ y cambia el nombre del directorio E:\test a E:\test1, NetWorker no respalda el directorio E:\test1 sin habilitar los directorios cuyo nombre de respaldo cambió. 

Cuando el campo de saveset contiene E:\test y usted cambia el nombre del directorio E:\test a E:\test1, NetWorker realiza un respaldo del directorio E:\test1 cuando se habilita la opción Backup renombrando directorios.

NetWorker lleva a cabo una comprobación de índice para los cambios de directorio desde el último estado completo, pero esto puede depender de que una conexión de Client Direct se complete correctamente antes de llegar a esta etapa.

Resolución

Seleccione Backup renamed Directories.

De manera predeterminada, si cambia el nombre de un directorio después de un respaldo completo, pero no cambian archivos ni subcarpetas en el directorio, NetWorker no incluye el directorio cuyo nombre cambió en respaldos incrementales subsiguientes. Para incluir directorios con nombre nuevo en un respaldo incremental, seleccione el atributo Backup renamed directories en el recurso Client.

Esta configuración se cambia desde NetWorker Management Console, abriendo las propiedades del cliente:
 

Captura de pantalla de la pestaña Client Properties en NetWorker Management Console
Figura 1: Captura de pantalla de la pestaña Client Properties en NetWorker Management Console


La pestaña General de NetWorker Management Console tiene una casilla de verificación para directorios con nombre de respaldo renombrados:
 

Captura de pantalla de la casilla de verificación para directorios con cambio de nombre de respaldo en la pestaña General de NetWorker Management Console
Figura 2: Captura de pantalla de la casilla de verificación para directorios con cambio de nombre de respaldo en la pestaña General de NetWorker Management Console 

Corrija la conexión de Client Direct entre el cliente y Data Domain.

Tener comunicaciones directas entre el Cliente y el PowerProtect DD normalmente es preferible, por lo que debemos asegurarnos de que cualquier problema de conectividad entre el cliente y PowerProtect DD se resuelven:

Actualizar resolución de host:

Asegúrese de que el archivo /etc/hosts o las entradas del sistema de nombre de dominio (DNS) en el cliente y Data Domain estén configuradas correctamente.
Ambos sistemas deben resolver los nombres de host del otro con precisión.

NetWorker: Prácticas recomendadas de solución de problemas de resolución de nombres

Verifique la conectividad de red:

Comuníquese con su equipo de red para asegurarse de que los siguientes puertos estén abiertos y accesibles en ambas direcciones:

111
2049
2051
2052


Una vez resueltos los problemas de conectividad, ejecute el respaldo para que el cliente verifique que el respaldo se complete correctamente y sin errores.

Los puertos y la resolución de nombres se pueden verificar en los sistemas NetWorker mediante nsrports el comando:

nsrports -t HOSTNAME -p PORT

Deshabilite Client Direct en las propiedades del cliente

Si no puede realizar respaldos de Client Direct desde el cliente a Data Domain y no puede reparar el enlace directo, puede ser necesario deshabilitar Client Direct por completo en la pestaña General de propiedades del cliente:

Captura de pantalla de la interfaz de usuario en la que se muestra la pestaña General de las propiedades del cliente

 

Productos afectados

NetWorker
Propiedades del artículo
Número del artículo: 000199928
Tipo de artículo: Solution
Última modificación: 20 oct 2025
Versión:  5
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