Pérdida de memoria NTP de DELL Networking N2200 y N3200 en 6.8.0.1, 6.8.1.0 y 6.8.1.2
Resumen: En este artículo, se explica una pérdida de memoria causada por NTP en las plataformas Dell N2200 y N3200 para 6.8.0.1, 6.8.1.0 y 6.8.1.2.
Síntomas
Plataformas afectadas:
N3208PX-ON, N3224T-ON, N3224F-ON, N3248X-ON, N3248TEON, N3224PX-ON, N3224P-ON, N3248P-ON, N3248PXE-ON, N2224X-ON, N2224PX-ON, N2248X-ON y N2248PX-ON
Versiones de firmware afectadas:
6.8.0.1, 6.8.1.0 y 6.8.1.2
Impacto:
todos los clientes que utilizan NTP pueden verse afectados por este problema. La pérdida de memoria puede hacer que el switch se reinicie inesperadamente o deje de responder. Además, es posible que algunas aplicaciones dejen de funcionar.
¿Cómo se necesita el registro para que se produzca este problema?
El impacto puede tardar un par de meses o incluso un año en manifestarse.
Pasos para verificar si este problema afecta al sistema:
La única manera de verificar si el sistema se ve afectado es mediante el uso de una herramienta de monitoreo de memoria o la comprobación manual si hay un agotamiento de la memoria.
En la consola del switch, SSH, telnet, monitoree la memoria mediante el comando:
show memory cpu Sample Output: DELLOS6#show memory cpu Total Memory................................... 3994960 KBytes Available Memory Space......................... 2370596 KBytes
El espacio libre disponible se reduce gradualmente.
Causa
El desencadenante de este problema es el agotamiento lento de la memoria causado por NTP. Aquí, la pérdida del conector NTP conduce a una reducción gradual de la memoria con cada actualización de NTP.
Resolución
Solución alternativa:
Como solución alternativa, deshabilite NTP en el switch.
Sintaxis del comando:
DELLOS6#configure DELLOS6(config)#no ntp server <IP address>
Solución:
Este problema se soluciona en la versión de firmware 6.8.1.3. Actualice la versión actual del firmware a la versión más reciente. El firmware está disponible para su descarga en el sitio web de soporte de Dell.