NVP-vProxy: La operación de respaldo o restauración de vm falla con el mensaje "Failed to lock Virtual Machine for backup: Otra operación "File-Level-Recover" de EMC vProxy está activa en vm-####"
Resumen: Una operación de respaldo o restauración de VM realizada mediante el dispositivo vProxy de NetWorker VMware Protection (NVP) falla e indica "Failed to lock Virtual Machine" (No se pudo bloquear la máquina virtual) ...
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Síntomas
La integración de NetWorker VMware Protection se configura con el vProxy Appliance. Los respaldos de vProxy fallan, lo que indica que otra operación de restauración a nivel de archivos (FLR) de vProxy está activa y no puede bloquear la máquina virtual (VM) para el respaldo.
YYYY/MM/DD HH:MM:SS ERROR: [@(#) Build number: 43] Failed to lock Virtual Machine for backup: Another EMC vProxy operation 'File-Level-Recover' is active on VM vm-####
Según la operación que se realice, es decir, respaldo, FLR, etc. El error puede parecer levemente diferente. La coherencia será "failed to lock virtual machine" y "another vProxy operation is active on VM".
Causa
Los flujos de trabajo de FLR y respaldo de vProxy establecen atributos de VM al comienzo de la operación para evitar varias operaciones de vProxy en la misma VM. El flujo de trabajo de respaldo eliminará los atributos de vm al final de la operación para permitir otras operaciones contra la VM. Un flujo de trabajo anterior de FLR de vProxy encontró un problema durante la ejecución y los atributos de vm no se eliminaron.
Resolución
La utilidad ProxyHC se puede utilizar para borrar cualquier atributo o artefacto sobrante que pueda quedar después de un respaldo o una recuperación fallidos o interrumpidos.
Puede encontrar instrucciones para descargar y configurar ProxyHC aquí:
NVP-vProxy: Cómo utilizar la herramienta de evaluación del estado ProxyHC en el dispositivo
vProxy1. Asegúrese de que no haya respaldos ni recuperaciones en ejecución en vCenter.
2. Configure ProxyHC en el vProxy utilizado para el respaldo o la recuperación
fallidos 3. Ejecute el siguiente comando:
Si esta operación no se puede utilizar debido a otros trabajos en ejecución o si no funciona. Se puede completar el siguiente procedimiento para borrar manualmente las anotaciones en una VM.
El atributo "Sesión de FLR de vProxy de Dell EMC" se debe restablecer (borrar) manualmente a través del cliente vSphere. Esta es una descripción general del procedimiento:
Figura 1: VM "Editar atributos personalizados..." en vSphere.
B. En la pestaña Resumen de VM, seleccione "Editar" la sección Anotaciones.
Puede encontrar instrucciones para descargar y configurar ProxyHC aquí:
NVP-vProxy: Cómo utilizar la herramienta de evaluación del estado ProxyHC en el dispositivo
vProxy1. Asegúrese de que no haya respaldos ni recuperaciones en ejecución en vCenter.
2. Configure ProxyHC en el vProxy utilizado para el respaldo o la recuperación
fallidos 3. Ejecute el siguiente comando:
ProxyHC disk tasks cleanup
Si esta operación no se puede utilizar debido a otros trabajos en ejecución o si no funciona. Se puede completar el siguiente procedimiento para borrar manualmente las anotaciones en una VM.
El atributo "Sesión de FLR de vProxy de Dell EMC" se debe restablecer (borrar) manualmente a través del cliente vSphere. Esta es una descripción general del procedimiento:
- Abra vSphere Web Client.
- Ubique la VM afectada en el inventario de VMware.
- Realice una de las siguientes opciones para acceder a las anotaciones:
Un. Haga clic con el botón secundario en la VM, seleccione Tags > Custom Attributes y, a continuación, edite los atributos personalizados:
Figura 1: VM "Editar atributos personalizados..." en vSphere.
B. En la pestaña Resumen de VM, seleccione "Editar" la sección Anotaciones.
Figura 2: Atributos personalizados de vm del cliente web de vSphere.
- Seleccione el atributo Sesión de FLR de vProxy de Dell EMC y, a continuación, haga clic en la X para eliminarla.
Figura 3: Pasos necesarios para eliminar un atributo de VM.
NOTA: De manera opcional, puede eliminar todos los atributos "Dell EMC". Se volverán a crear cuando se realice la siguiente operación de respaldo, restauración o limpieza de vProxy.
- Seleccione "Aceptar" en la ventana Editar anotaciones.
Información adicional
Productos afectados
NetWorkerProductos
NetWorkerPropiedades del artículo
Número del artículo: 000050701
Tipo de artículo: Solution
Última modificación: 18 set. 2025
Versión: 5
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