NVP – vProxy: Operace zálohování nebo obnovení virtuálního počítače se nezdaří a zobrazí se chyba "Failed to lock Virtual Machine for backup: Další operace EMC vProxy "File-Level-Recover" je aktivní na virtuálním počítači vm-#####"
Resumen: Operace zálohování nebo obnovení virtuálního počítače pomocí zařízení NetWorker VMware Protection (NVP) vProxy selže a zobrazí se zpráva "Failed to lock Virtual Machine".
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
Integrace řešení NetWorker VMware Protection je konfigurována pomocí zařízení vProxy. Zálohování vProxy selže, což znamená, že je aktivní jiná operace obnovení na úrovni souboru vProxy (FLR) a není možné zamknout virtuální počítač (VM) k zálohování.
YYYY/MM/DD HH:MM:SS ERROR: [@(#) Build number: 43] Failed to lock Virtual Machine for backup: Another EMC vProxy operation 'File-Level-Recover' is active on VM vm-####
V závislosti na prováděných operacích, tj. zálohování, FLR atd. Chyba se může mírně lišit. Konzistence bude "failed to lock virtual machine" a "Another vProxy operation is active on VM."
Causa
Pracovní postupy vProxy Backup a FLR na začátku operace nastaví atributy virtuálního počítače, aby nedocházelo k více operacím vProxy na stejném virtuálním počítači. Pracovní postup zálohování odstraní atributy virtuálního počítače na konci operace, aby bylo možné provádět jiné operace vůči virtuálnímu počítači. V předchozím pracovním postupu vProxy FLR došlo během spuštění k problému a atributy virtuálních počítačů nebyly odebrány.
Resolución
Nástroj ProxyHC lze použít k vymazání všech levých atributů nebo artefaktů, které mohou být ponechány po selhání nebo přerušení zálohování nebo obnovení.
Pokyny ke stažení a nastavení proxyHC naleznete zde:
NVP-vProxy: Jak používat nástroj kontroly stavu ProxyHC v zařízení
vProxy1. Zkontrolujte, zda v nástroji vCenter neběží žádné zálohy ani obnovy.
2. Nastavení proxyHC v systému vProxy použitém pro neúspěšné zálohování/obnovení
3. Zadejte následující příkaz:
Pokud tuto operaci nelze použít kvůli ostatním spuštěným úlohám nebo pokud tato operace nefunguje. Chcete-li ručně vymazat poznámky na virtuálním počítači, lze dokončit následující postup.
Atribut "Dell EMC vProxy FLR Session" je nutné resetovat (vymazat) ručně prostřednictvím klienta vSphere. Zde je obecný přehled postupu:
Obrázek 1: Virtuální počítač "Upravit vlastní atributy..." vsphere.
B. Na kartě VM Summary vyberte možnost "Edit" v části Annotations.
Pokyny ke stažení a nastavení proxyHC naleznete zde:
NVP-vProxy: Jak používat nástroj kontroly stavu ProxyHC v zařízení
vProxy1. Zkontrolujte, zda v nástroji vCenter neběží žádné zálohy ani obnovy.
2. Nastavení proxyHC v systému vProxy použitém pro neúspěšné zálohování/obnovení
3. Zadejte následující příkaz:
ProxyHC disk tasks cleanup
Pokud tuto operaci nelze použít kvůli ostatním spuštěným úlohám nebo pokud tato operace nefunguje. Chcete-li ručně vymazat poznámky na virtuálním počítači, lze dokončit následující postup.
Atribut "Dell EMC vProxy FLR Session" je nutné resetovat (vymazat) ručně prostřednictvím klienta vSphere. Zde je obecný přehled postupu:
- Otevřete webový klient vSphere.
- V inventáři VMware vyhledejte dotčený virtuální počítač.
- Pro přístup k anotacím proveďte jednu z následujících možností:
A. Klikněte pravým tlačítkem na virtuální počítač, vyberte možnost Tags & Custom Attributes a poté možnost Edit Custom Attributes:
Obrázek 1: Virtuální počítač "Upravit vlastní atributy..." vsphere.
B. Na kartě VM Summary vyberte možnost "Edit" v části Annotations.
Obrázek 2: Vlastní atributy virtuálního počítače webového klienta vSphere.
- Vyberte atribut Relace Dell EMC vProxy FLR a poté jej kliknutím na X smažte.
Obrázek 3: Postup odstranění atributu virtuálního počítače.
POZNÁMKA: Volitelně můžete odstranit všechny atributy "Dell EMC". Znovu se vytvoří, když se provede další operace zálohování, obnovení nebo čištění systému vProxy.
- V okně Edit Annotations vyberte možnost "OK".
Información adicional
Productos afectados
NetWorkerProductos
NetWorkerPropiedades del artículo
Número del artículo: 000050701
Tipo de artículo: Solution
Última modificación: 18 set. 2025
Versión: 5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.