NetWorker:一般的なNetWorkerの問題をサポートするために収集および提供するログ ファイルと情報

Resumen: NetWorkerのトラブルシューティング ケースを送信または引き継ぐ際に、一般的に要求され、必要なデータに関する指示。

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Síntomas

テクノロジーは確定的であることに注意してください。定義上、以前は機能していたところで障害が発生した場合は、何らかの変更が必要です。作業履歴のない新しく実装されたコンポーネントは、トラブルシューティングと大きく異なります。

明確で識別可能な変更:
  • ソフトウェアのバージョンまたは構成の変更
  • ハードウェアまたはトランスポートの変更または再構成
  • 停電、転送障害、ディスク障害などの環境イベント
未検出の変更
  • ソフトウェア リソースまたはファイル システムの破損
  • ネットワーク、SAN、またはホストでの動作の競合
  • 他のチームによる転送またはホストの再構成
  • データ ボリュームまたは転送トラフィックの増加
  • アラートを発行しない致命的でない環境イベント
延長レビューおよび技術的なトラブルシューティング作業のために問題を準備する場合は、次の一般的な指示が確認されていることを確認します。これらのアイテムにより、十分なデータが機械的に収集され、問題を適切に見極めるために正しい質問が行われます。
 

Causa

問題を明確に定義します。
  • 失敗している、逸脱している、または質問の対象となっている操作または属性はですか? 利用可能な障害シーケンスの詳細は何ですか?
  • バイナリ、SAN/ネットワーク スイッチなど、関連する特定のコンポーネントとデータ パスはどれですか。ソフトウェアバージョンストレージタイプまたはインスタンス
  • 通常のワークフローのどこで問題が発生しますか? 別のワークフローを使用して同じ操作を試行した場合、結果は異なりますか?
  • 問題が最初に発生したのはいつですか? どれくらいの期間が続くのですか? それ以降、どのような日付/時刻が発生しましたか? 最近の変更が特定されましたか?
  • 問題は、 一貫して、または断続的にどのように発生しますか? 問題が発生した後、問題はどのように軽減されますか?
  • 問題に関与しているホストはですか?また、そのプロパティ(NetWorkerホスト タイプ、NetWorkerバージョン、名前、IP、OS、CPUなど)は何ですか?
  • 類似のコンポーネントが影響を受けない場合、一部のコンポーネントが影響を受けるのはなぜですか? 影響を受けないコンポーネントと同様の違いは何ですか?

Resolución

汎用ログ

ほとんどのNetWorkerログは、NSRGETユーティリティーを使用して、WindowsおよびLinux NetWorkerサーバー、ストレージ ノード、クライアントから収集できます。ユーティリティは、次の場所からダウンロードできます。

https://central.dell.com/solutions/Networker-Tools


1.NSRGETユーティリティを任意の一時ディレクトリに解凍します
。 2.NSRGETの使用方法については、次の文書を参照してください。NetWorker:NSRGet NetWorkerデータ コレクション ツール

の使用方法NetWorkerで使用される次のKBの詳細ログ: NetWorker:ログ ファイルと場所


関連するすべてのNetWorkerホスト(サーバーおよびストレージ ノードを含む)から次の情報を収集します。

  • NetWorkerデバッグ ファイル: [nsr]/debugのディレクトリー リスト
    • このディレクトリは空にする必要があります。/nsr/debugの下に問題が発生した日付と一致するファイルがある場合は、問題を示している可能性があります。
  • NetWorkerコア ファイル: 
    • Linuxの場合/nsr/コア
    • Windowsの場合:C:\Program Files\EMC NetWorker\nsr\cores
  • NetWorkerアプリ ログ: [nsr]/appsのzip。[nsr]/applogsのzip。[nsr]/rmagentps/logsのzip。[nsr]/logs/lib*、nsrbr*、nsrsnap**のバンドル
  • NetWorkerログ: [nsr]/logs/daemon.raw、[nsr]/logs/networkr.raw
  • NetWorkerクライアント構成: zip:[nsr]/res/nsrladb,[nsr]/res/serversファイル(存在しない場合あり)、[nsr]/res/nsrdb(NetWorkerサーバーの場合)
    • これらは、NSRGETユーティリティーによって収集されます。
  • スタートアップ スクリプト: Solaris & Linux - /etc/init.d/networker、HPUX - /sbin/init.d/networker
  • バックアップ ポリシー ログ: 
    • Linuxの場合/nsr/logs/policy/POLICY_NAME/WORKFLOW_NAME
    • Windowsの場合:C:\Program Files\EMC NetWorker\nsr\logs\policy\POLICY_NAME\WORKFLOW_NAME
  • NetWorkerのバージョンとビルドNetWorker:NetWorkerソフトウェアのバージョンを識別する方法
  • NetWorker用にインストールされている既知のパッチ
  • オペレーティング システム、エディション、パッチ レベル、CPU、ビット幅(32/64ビット)
    • Linux: cat /etc/*release ; uname -m
    • Windows: systeminfo | findstr 「OS Type」
    • NSRGETまたはEMCREPORTSでは、OSのバージョンとシステム アーキテクチャについても詳しく説明します。
  • EMCレポート ユーティリティ:https://www.dell.com/support/home/en-us/product-support/product/emcreports/drivers
    • EMCレポートは、OSの詳細と構成、オペレーティング システム メッセージ、イベント ログなど、追加のホスト情報を収集します。この情報の一部はNSRGETでも収集されます。一方、EMCレポートは、より運用固有のログです。EMCレポートは、NSRGETと連携して収集することも、NetWorkerクライアント ソフトウェアがインストールされていないシステムで収集することもできます。たとえば、vProxyによってバックアップされたVMware仮想マシンなどです。 
  • コアダンプ:NetWorker:プロセスコアダンプのトラブルシューティング
  • 名前解決の問題が疑われる場合: NetWorker:名前解決のトラブルシューティングのベスト プラクティス

NetWorkerサーバーからのみ次の情報を収集します。
  • NetWorkerリソース データベース: [nsr]/res/nsrdbの圧縮コピー
  • NetWorkerメディア データベース: nsrmmdbasmを使用してNetWorkerメディア データベースをエクスポートする方法
  • NSRGETは、必要なほとんどのログを収集します。ただし、次の情報は収集されません。
    • AUTHC(認証)ログ:
      • Linuxの場合/nsr/logs/authc
      • Windowsの場合:C:\Program Files\EMC NetWorker\nsr\authc-server\tomcat\logs
    • NmC(NetWorker Management Console)(gstd)ログ:
      • Linuxの場合/opt/lgtonmc/logs/
      • Windowsの場合:C:\Program Files\EMC NetWorker\Management\GST\logs
    • NetWorker Webユーザー インターフェイス(NWUI)ログ:
      • Linuxの場合/opt/nwui/logs
      • Windowsの場合:C:\Program Files\EMC NetWorker\nwui\logs
NetWorkerストレージ ノード(サーバーを含む)から次の情報を収集します。
  • NetWorker検出コマンド: inquire -lc出力
  • NetWorkerバスの尋問: lusbinfo / lusbinfo -v 出力
  • NetWorker SJIコマンドの出力: sjisn [x.y.z]、sjirdtag [x.y.z]、sjirjc [x.y.z] (ここで、x.y.zはSCSIアドレスまたはデバイス ファイル ハンドル)
  • NetWorker CDIコマンドの出力: cdi_inq -f [dev] -v、cdi_get_config -f [dev] -v、cdi_get_status -f [dev] -v、cdi_get_blocksize -f [dev] -v (dev はデバイス ファイル ハンドル)
  • NetWorkerデバイスとマウント状態のサマリー: Nsrmm
  • NetWorkerのシンプルなオートチェンジャー出力: nsrjb -C [jukebox_name]
  • NetWorkerディスクの詳細: 影響を受けるAFTD/DD/FTD構造の再帰的なディレクトリー リストに加え、ディスク デバイスの詳細とホストへの接続方法の詳細。
  • オペレーティング システム、エディション、パッチ レベル、CPU、ビット幅(32/64ビット)
    • Linux: cat /etc/*release ; uname -m
    • Windows: systeminfo | findstr 「OS Type」
    • NSRGETまたはEMCREPORTSでは、OSのバージョンとシステム アーキテクチャについても詳しく説明します。
  • NSRGETおよび/またはEMCレポートは、サポートエンゲージメントに推奨されます。
注:上記のデバイス コマンドと、以下に示すOSデバイス コマンドは、アクティブなデバイスで使用されている場合にSCSIリセットを引き起こす可能性があります。システムに接続されているすべてのテープ デバイス、または指定されたテープ デバイスがすべてのホスト インスタンスでアイドル状態になっている場合にのみ、必要に応じて使用します。

影響を受けるNetWorker License Managerホストから次の情報を収集します。
  • ライセンス コマンド出力: nsrlic -C
  • NetWorkerライセンス データベース: zip: [nsr]/res/lgtolm.res, [nsr]/res/lictype.res, [nsr]/logs/lgtolmd.log, [nsr]/logs/license*
影響を受ける NetWorker管理コンソール ホストから次の情報を収集します。
  • オペレーティング システム、エディション、パッチ レベル、CPU、ビット幅(32/64ビット)
    • Linux: cat /etc/*release ; uname -m
    • Windows: systeminfo | findstr 「OS Type」
    • NSRGETまたはEMCREPORTSでは、OSのバージョンとシステム アーキテクチャについても詳しく説明します。
  • 管理コンソール ログ(gstd.raw - 理想的にはレンダリング): 
  • ビルド番号を含むNMCバージョン
  • Oracle Java JREバージョン:https://www.java.com/en/download/help/version_manual.html このハイパーリンクをクリックすると、デル・テクノロジーズ以外のWebサイトにアクセスします。  
  • NetWorker Runtime Environment(NRE):
    • Linuxの場合 
      • rpm -qa |grep nre
      • /opt/nre/java/latest/bin/java -version
    • Windowsの場合: 
      • Javaのバージョンは、次の下に表示されます。C:\Program Files\NRE\java\jre#.#.#_##
        • 複数のJavaフォルダーがリストされている場合は、NetWorkerによって現在使用されているパスのシステム環境変数JAVA_HOMEまたはNSR_JAVA_HOMEを確認します。
      • NREのバージョンは、[コントロール パネル]の[プログラムと機能]の下に表示されます
  • Java Webstartファイル: [nmc]/web/gconsole.jnlp
  • NMC構成ファイル: [nmc]/etc/gstd.conf
NetWorker VMware Protection(NVP)vProxyアプライアンス:

Productos afectados

NetWorker

Productos

NetWorker Series
Propiedades del artículo
Número del artículo: 000079239
Tipo de artículo: Solution
Última modificación: 26 sept 2023
Versión:  4
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