NVP vProxy: Os backups de VM falham com o erro "VDDK: 13: Você não tem direitos de acesso a este arquivo... unable to open virtual disk in hotadd mode"
Resumen: Os backups de VM configurados para acesso hotadd só falham com o erro VDDK 13 "you do not have access rights to this file" quando o vProxy não tem acesso ao datastore aos arquivos da VM. ...
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
O NVP vProxy só é compatível com os modos de transferência "hotadd" e "nbd".
Os backups de VM do NVP vProxy estão falhando com o seguinte erro:
Os backups de VM do NVP vProxy estão falhando com o seguinte erro:
YYYY/MM/DD HH:MM:SS TRACE: [@(#) Build number: ###] Opening source VMDK "[DATASTORE] VM_NAME/VM_NAME.vmdk" ...
YYYY/MM/DD HH:MM:SS INFO: [@(#) Build number: ###] Calling VixDiskLib_Open("[DATASTORE] VM_NAME/VM_NAME.vmdk")...
YYYY/MM/DD HH:MM:SS ERROR: [@(#) Build number: ###] VDDK Error: 13: You do not have access rights to this file.
YYYY/MM/DD HH:MM:SS ERROR: [@(#) Build number: ###] Failed to open source VMDK "[DATASTORE] VM_NAME/VM_NAME.vmdk".
YYYY/MM/DD HH:MM:SS ERROR: [@(#) Build number: ###] "Hard disk 1": BackupVmdk: "Hard disk 1": Unable to open Virtual Disk "[DATASTORE] VM_NAME/VM_NAME.vmdk" in "hotadd" mode.
YYYY/MM/DD HH:MM:SS ERROR: [@(#) Build number: ###] "Hard disk 1": BackupVmdk: "Hard disk 1": Unable to open Virtual Disk "[DATASTORE] VM_NAME/VM_NAME.vmdk" in "hotadd" mode.
YYYY/MM/DD HH:MM:SS ERROR: [@(#) Build number: ###] "Hard disk 1": BackupVmdk: Failed backup.
YYYY/MM/DD HH:MM:SS ERROR: [@(#) Build number: ###] Unable to backup virtual disk "Hard disk 1".
Causa
Por padrão, o modo de transferência "hotadd" é usado. Se o vProxy não tiver acesso direto ao datastore no qual a VM está em execução, ele retornará ao modo NBD para melhorar as chances de obter um backup bem-sucedido; No entanto, se o NBD estiver desativado (definido como 0 nas propriedades do vProxy), o backup apresentará falha.
Hotadd O VMware Backup Appliance ou o proxy externo monta diretamente o disco rígido da VM para ler os dados de backup. Esse modo exige que o proxy tenha acesso direto ao datastore da VM que você deseja fazer backup.
NBD O VMware Backup Appliance ou o proxy externo se conectará ao servidor ESX em que a VM está em execução pela rede IP, e os dados serão transferidos pela rede IP para o proxy. Como resultado, o modo NBD geralmente é mais lento do que o modo hotadd.
Hotadd O VMware Backup Appliance ou o proxy externo monta diretamente o disco rígido da VM para ler os dados de backup. Esse modo exige que o proxy tenha acesso direto ao datastore da VM que você deseja fazer backup.
NBD O VMware Backup Appliance ou o proxy externo se conectará ao servidor ESX em que a VM está em execução pela rede IP, e os dados serão transferidos pela rede IP para o proxy. Como resultado, o modo NBD geralmente é mais lento do que o modo hotadd.
Resolución
Para dar suporte ao modo hotadd, implemente um vProxy em um host ESXi que tenha um caminho para o armazenamento que contém os discos virtuais de destino para backup. O modo Hotadd requer o hardware VMware versão 7 ou posterior.
OU
Habilitar NBD no host do vProxy (nas propriedades do vProxy). É recomendável usar hotadd via nbd, pois o hotadd tem melhor desempenho normalmente e o nbd utiliza a rede de gerenciamento do host ESXi.
Consulte o "Guia de integração do NetWorker VMware" para sua versão do NetWorker para obter recomendações de "desempenho e escalabilidade". Esta documentação está disponível por meio de: https://www.dell.com/support/home/product-support/product/networker/docs
OU
Habilitar NBD no host do vProxy (nas propriedades do vProxy). É recomendável usar hotadd via nbd, pois o hotadd tem melhor desempenho normalmente e o nbd utiliza a rede de gerenciamento do host ESXi.
Consulte o "Guia de integração do NetWorker VMware" para sua versão do NetWorker para obter recomendações de "desempenho e escalabilidade". Esta documentação está disponível por meio de: https://www.dell.com/support/home/product-support/product/networker/docs
Productos afectados
NetWorkerProductos
NetWorkerPropiedades del artículo
Número del artículo: 000160825
Tipo de artículo: Solution
Última modificación: 05 jun 2025
Versión: 4
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.