Alertas de PowerStore: Alertas de capacidad completa del sistema

Resumen: En este artículo, se analizan las alertas relacionadas con el modo de protección contra escritura (WPM) de capacidad completa y las alertas resultantes.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Cuando un PowerStore encuentra un problema, se genera una alerta de error para ayudar a identificar el problema. En este artículo, se explican las distintas causas posibles y las correcciones pertinentes para estas alertas de error. Si el problema no se resuelve con la corrección proporcionada, consulte las opciones de contacto de soporte técnico.
 

SLN317187_en_US__1icon Nota: ¿No encuentra la información que necesita? Contáctenos mediante el formulario de comentarios que se encuentra en la parte inferior de este artículo.


Causa

Cuando un dispositivo alcanza su capacidad completa, entra en una condición conocida como modo de protección contra escritura (WPM). En WPM, todos los volúmenes pasan a ser de solo lectura y se requiere una reparación del sistema.

Para obtener una explicación de cómo se calcula la capacidad física, consulte el artículo de la base de conocimientos 188491: PowerStore: Cómo se calcula la capacidad física de PowerStore.

Resolución

Identificación de la alerta
DATA_PATH_WRITE_PROTECT_MODE_ENTER DATA_PATH_APP_EXIT_WPM_WITH_ENOUGH_MD_NOTIFY
DATA_PATH_APP_WPM_SHORT_OF_MD_NOTIFY
Texto de la alerta La < capacidad de datos del usuario o del sistema > ha alcanzado su capacidad completa.
El dispositivo salió del estado de protección contra escritura con 16 GB de capacidad libre.
El dispositivo no puede salir del modo de protección contra escritura debido a una capacidad insuficiente de datos del sistema.
Código de error (0x00200701)
(0x00201401)
(0x00201501)
Solución ¿Qué sucede cuando está en el modo de protección contra escritura (WPM)?
Cuando un dispositivo alcanza su capacidad completa, entra en una condición conocida como modo de protección contra escritura (WPM), en la que todos los volúmenes pasan a ser de solo lectura.
  • El 0x00B00702 de alerta (texto de alerta: El nivel de servicio está degradado, las funciones de administración son limitadas y las I/O se ven afectadas) se eleva.
  • Las I/O de escritura fallan
  • Es posible que las operaciones como instantáneas y replicación se deshabiliten.
  • Ninguna de las métricas (capacidad y rendimiento) está disponible. En PowerStore 3.0 y versiones posteriores, la tabla de métricas se actualiza mientras se está en WPM.
Recomendación: el sistema no debe superar el umbral del 85 %.
 

Para obtener una explicación de cómo se calcula la capacidad física, consulte el artículo de la base de conocimientos 188491: PowerStore: Cómo se calcula la capacidad física de PowerStore.


Causa

La capacidad física total de PowerStore consta de datos de usuario y datos del sistema.

En PowerStoreOS 3.0 y versiones superiores, se muestra lo siguiente en PowerStore Manager. Al usuario se le presenta un desglose más preciso de los datos del usuario y de los datos del sistema:
image.png
En PowerStoreOS anterior a 3.0, se muestra lo siguiente en PowerStore Manager. Al usuario solo se le presenta un desglose de la capacidad física utilizada:

:
image.png

 

Cuando el sistema alcanza el 70 % de su capacidad, se generan alertas para advertir sobre la falta de espacio. Consulte el artículo 000123351 de la base de conocimientos: Alertas de PowerStore: Utilización de la capacidad.

Si el usuario no realiza ninguna acción y el sistema alcanza el 100 %, el sistema ingresa al modo de protección contra escritura (WPM), lo que indica que todos los volúmenes ingresan al modo de solo lectura, y se genera la alerta 0x00200701.

El 0x00200701 de alerta indica un problema de espacio con los datos del usuario o del sistema.

Nota: Si un nodo está inactivo durante un período prolongado, puede provocar un aumento de la capacidad física.

¿Cómo conocemos la causa raíz de WPM?

El usuario puede determinar la causa raíz de la condición de WPM según el texto de la alerta:

  • User Data: (0x00200701) los datos de usuario han alcanzado su capacidad máxima.
  • System Data: (0x00200701) Los datos del sistema han alcanzado su capacidad máxima.

Según el tipo de condición de WPM (datos del usuario o datos del sistema), se determina la solución alternativa.



Solución

La recuperación de una condición OOS depende del motivo de la OOS. La causa de la condición de WPM se encuentra en el texto de la alerta:

  • User Data: (0x00200701) los datos de usuario han alcanzado su capacidad máxima.
  • System Data: (0x00200701) Los datos del sistema han alcanzado su capacidad máxima.

Según el tipo de condición de WPM (datos del usuario o datos del sistema), se determina la solución alternativa.


 

1. Datos de usuario

Utilice una de las siguientes opciones:

  • Add Drives: (esta es la opción recomendada).
    • Consulte con su equipo de cuentas para analizar sus requisitos de capacidad y agregar más unidades.
  • Eliminar volúmenes o instantáneas.
    • Si el usuario requiere información sobre qué volúmenes o instantáneas eliminar, escale a Servicios globales para obtener orientación.

Información adicional

  1. Antes de llevar a cabo cualquier acción, debe realizar lo siguiente:
    1. Detenga todas las I/O en el arreglo (deshabilite los puertos FC/iSCSI en el switch) para evitar volver a ejecutarse en WPM.
    2. Ponga en pausa todas las programaciones de instantáneas, la replicación y cualquier automatización externa relacionada con la administración de volúmenes.
  2. Para salir de la condición de WPM, el dispositivo debe recuperar un mínimo de 16 GB de espacio. Para hacerlo, el usuario debe eliminar un volumen con al menos 16 GB de datos únicos.
    Si el usuario logra recuperar dicho espacio y hay suficiente espacio para los datos del sistema, alerte 0x00200701 (Texto de alerta: Los datos de usuario han alcanzado su capacidad completa) borra y 0x00201401 de alerta (Texto de alerta: El dispositivo salió del estado de protección contra escritura con 16 GB de capacidad libre) Aparece.
  3. Una vez en este estado, los volúmenes pasan al acceso de lectura/escritura, y el usuario debe continuar recuperando espacio hasta que el dispositivo alcance el 85 % de la capacidad física utilizada.
    1. Se recomienda encarecidamente eliminar volúmenes o instantáneas uno a la vez.
    2. Consulte el manual del sistema operativo específico para obtener instrucciones sobre cómo recuperar espacio del lado del host.
  4. Una vez que alcance el 85 % de la capacidad física utilizada, el usuario debe borrar manualmente la alerta 0x00201401.
  5. Nota: La recuperación de espacio mediante la eliminación de instantáneas o volúmenes requiere inicialmente espacio adicional para los datos del sistema y, por lo tanto, puede provocar la 0x00201501 de alerta (Texto de alerta: El dispositivo no puede salir del modo de protección contra escritura debido a una capacidad insuficiente de datos del sistema.
  6. PowerStoreOS 1.0.3 presentó un nuevo script de servicio (svc_volume_space_metrics) que permite al usuario ver información adicional sobre las estadísticas de espacio de volumen cuando el dispositivo está en WPM.
    Para obtener más información, consulte la sección "Cómo usar svc_volume_space_metrics" más adelante en este artículo de la base de conocimientos.
 

2. Datos del sistema

Utilice una de las siguientes opciones:

  • Add Drives: (esta es la opción recomendada).
    • Consulte con su equipo de cuentas para analizar sus requisitos de capacidad y agregar más unidades.
  • Si el usuario no puede agregar unidades, escale el problema al soporte técnico para obtener ayuda.
Esta información se puede ver en el tablero de capacidad de volumen.
En este ejemplo, la eliminación del siguiente volumen recupera 59,8 GB de espacio que se puede utilizar para los datos de usuario o del sistema.

Tenga en cuenta que los datos del sistema requieren un mínimo de alrededor de 100 GB de espacio único para poder expandirse. A veces, puede requerir 200 GB de espacio para expandirse correctamente.
image.png


Información adicional

  1. Por lo general, cuando un dispositivo ingresa a WPM debido a los datos del sistema, los datos de usuario también se quedan sin espacio. 
    Esto se debe a que no queda capacidad de expansión (ya sea datos del sistema o datos de usuario).
  2. Para salir de WPM, por lo general, el usuario debe agregar unidades adicionales y escalar verticalmente el dispositivo.
  3. Cuando el sistema emite la alerta 0x00200701 (Texto de alerta: La capacidad del sistema alcanzó su capacidad máxima.) , indica que los datos del sistema se quedaron sin espacio y no se pueden expandir.
  4. Evite eliminar volúmenes en esta condición y escale a Servicios globales para obtener soporte. 



Cómo usar svc_volume_space_metrics

  1. PowerStoreOS 1.0.3 presentó un script de servicio que permite a los usuarios, cuando están en WPM, ver información adicional sobre cada árbol de volúmenes.
  2. Para ejecutar el script, SSH debe estar habilitado en el dispositivo especificado y el usuario debe conectarse mediante SSH a la IP del clúster mediante la cuenta de servicio.
  3. Cuando se intenta ejecutar este script de servicio cuando no está en WPM, el script de servicio falla.

  4. Cuando el dispositivo se queda sin espacio, el usuario puede ejecutar el script y ver información adicional, como la siguiente:
    Family Unique Physical Used: representa los datos únicos (comprimidos) que este volumen y toda su familia (instantáneas y clones) liberan si este volumen se elimina.
    Ejemplo: 

    [SVC:service@68R1BW2-A user]$ svc_volume_space_metrics
    2020-10-29 12:28:33,997 - INFO - event_client init() address: localhost node: A
    2020-10-29 12:28:34,248 - INFO -  PyCycloneDp.init localhost
    2020-10-29 12:28:34,318 - PyCycloneDp - INFO - logging in PyCycloneDp.__init__
      
    Namespace state is ro-oos
    Retrieve family space stats from DP namespace. It will take some time...
    2020-10-29 12:28:35,972 - INFO - event_client init() address: localhost node: A
    2020-10-29 12:28:36,175 - INFO -  PyCycloneDp.init localhost
    2020-10-29 12:28:36,220 - PyCycloneDp - INFO - logging in PyCycloneDp.__init__
      
    --------------------------------------+------------------------------------------------------+-------------+----------------+----------------+-----------+----------
                  Family ID               |             Primary Volume/FS/vVol Name              |     Type    | Family Unique  | Family Shared  |   No. of  |  No. of
                                          |                                                      |             | Physical Used  |  Logical Used  |   Clones  | Snapshots
    --------------------------------------+------------------------------------------------------+-------------+----------------+----------------+-----------+----------
     d301959c-6eb9-4e23-967a-e0b3cdf06bea |                     labtea-vol-1                     |Block        |        97.91 GB|       486.36 GB|     0     |     1
     6c97fdd8-5b01-44ef-adaf-047449f83c27 |                     labtea-vol-2                     |Block        |        99.47 GB|       492.30 GB|     0     |     1

     


 
Identificación de la alerta DATA_PATH_WRITE_PROTECT_MODE_EXTREMELY_HIGH 
Texto de la alerta La utilización del espacio de %(tier_name) es extremadamente alta.
Código de error 0x00200703
Impacto Es posible que varios servicios internos (como NAS y UI) no funcionen de manera óptima.
Solución  Causa:
Parte de la capacidad del dispositivo está reservada para servicios internos (como servicios principales de NAS, recopilaciones de datos, bases de datos internas, entre otros).
Cuando el dispositivo alcanza el modo de protección contra escritura (0x00200701), el usuario ya no puede escribir datos; sin embargo, los servicios internos aún pueden acceder a información importante (solo desde PowerStoreOS 3.0). Una vez que también se agota la capacidad reservada interna, se genera esta alerta, es posible que CP y SDNAS (y otros servicios) no funcionen de manera óptima.

Solución:
Comuníquese con el soporte técnico para obtener asistencia inmediata.

Información adicional

Problemas conocidos:

Productos afectados

PowerStore
Propiedades del artículo
Número del artículo: 000193645
Tipo de artículo: Solution
Última modificación: 13 jun 2025
Versión:  7
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