Sikkerhetskopier av Avamar SQL-klynge mislyktes med logghull og Sqlmeta.xml-fil

Résumé: Sikkerhetskopieringer av Avamar SQL-klynge mislyktes med logghull og sqlmeta.xml fil

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Inkrementelle sikkerhetskopier for en SQL-klynge eller SQL AG mislykkes med følgende feil:

Line 542: 2019/12/05-16:49:56.85100 [avsql_assist]  avspawn::run_and_wait back from wait error_num:536870919 wait_error:0
	Line 547: 2019-12-05 17:49:56 avsql Warning <7427>: Error loading SQL metadata
	Line 555: avtar Error <5195>: Path ".system_info\sqlmeta" not found in backup. (Element 'sqlmeta' at position 1 in search path '.system_info\sqlmeta' not found)
	Line 634: 2019-12-05 17:49:57 avsql Error <40418>: Skipping database 'sql-listener\VIEWSQL/viewupdmgr' due to the following reason: A log gap was identified or a full backup was not found.
	Line 755: 2019/12/05-16:50:04.42799 [avsql_assist]  avspawn::run_and_wait back from wait error_num:536870919 wait_error:0
	Line 755: 2019/12/05-16:50:04.42799 [avsql_assist]  avspawn::run_and_wait back from wait error_num:536870919 wait_error:0
	Line 762: 2019-12-05 17:50:04 avsql Warning <7427>: Error loading SQL metadata
	Line 770: avtar Error <5195>: Path ".system_info\sqlmeta" not found in backup. (Element 'sqlmeta' at position 1 in search path '.system_info\sqlmeta' not found)
	Line 849: 2019-12-05 17:50:05 avsql Error <40418>: Skipping database 'sql-listener\VIEWSQL/viewevent' due to the following reason: A log gap was identified or a full backup was not found.

 

Cause

Problemet med logggapet skyldes at sqlmeta.xml filen ikke leses fra tidligere SQL-sikkerhetskopier, og sikkerhetskopieringene mislykkes med sqlmeta.xml ikke funnet.

 

Résolution

Sjekk trinnene nedenfor:

  1. Opprett "c:\temp" hvis det ikke finnes, kjør som admin mens cd i Avamar BIN-mappen på den primære SQL-noden:

    avtar --list --debug --server=<Avamar_server> --id=MCUser --ap=MCUser_password --path=<path_to_client> --labelnum="91631" --noinfo --noconfig --logfile=c:\temp\backup_list.log
    Merk: --labelnum="91631" er reserveetikettnummeret.
  2. Sjekk om sqlmeta.xml-filen er til stede i utdataene fra kommandoen ovenfor.

    Hvis filen er til stede, kan du prøve å gjenopprette '.system_info' fra sikkerhetskopien ved å bruke kommandoen nedenfor:

    avtar -x --debug --server=<Avamar_server> --id=MCUser --ap=MCUser_password --path=<path_to_client> --labelnum="91631" --noinfo --noconfig ".system_info" --target=c:\temp\ --logfile=c:\temp\system_info.log --internal
  3. Hvis den sqlmeta.xml filen ikke finnes i sikkerhetskopietiketten (ovenfor), kan du prøve dette:

    • Kontroller om det er noen sqlmeta.xml fil i klyngen/den delte Var-katalogen. Hvis filen finnes, kan du slette eller flytte filen til en annen plassering.
    • Når du har slettet/flyttet filen, utfører du fullstendige sikkerhetskopier og deretter trinnvise sikkerhetskopier.
    • Kjøring av full sikkerhetskopiering etterfulgt av inkrementell sikkerhetskopiering sikrer opprettelse av en ny sqlmeta.xml fil.

 

Informations supplémentaires

Dette innholdet er oversatt til forskjellige språk: 
https://downloads.dell.com/TranslatedPDF/AR-SA_539981.pdf
https://downloads.dell.com/TranslatedPDF/DE_539981.pdf
https://downloads.dell.com/TranslatedPDF/ES_539981.pdf
https://downloads.dell.com/TranslatedPDF/ES-XL_539981.pdf
https://downloads.dell.com/TranslatedPDF/FR_539981.pdf
https://downloads.dell.com/TranslatedPDF/IT_539981.pdf
https://downloads.dell.com/TranslatedPDF/JA_539981.pdf
https://downloads.dell.com/TranslatedPDF/KO_539981.pdf
https://downloads.dell.com/TranslatedPDF/NL_539981.pdf
https://downloads.dell.com/TranslatedPDF/PT_539981.pdf
https://downloads.dell.com/TranslatedPDF/PT-BR_539981.pdf
https://downloads.dell.com/TranslatedPDF/RU_539981.pdf
https://downloads.dell.com/TranslatedPDF/SV_539981.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_539981.pdf
https://downloads.dell.com/TranslatedPDF/ZH-TW_539981.pdf

Produits concernés

Avamar

Produits

Avamar
Propriétés de l’article
Numéro d’article: 000057398
Type d’article: Solution
Dernière modification: 22 mai 2026
Version:  6
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.