Avamar : chemin de résolution de la capacité des métadonnées (en anglais)
Résumé: Cet article Chemin de résolution de la capacité de métadonnées peut être utilisé comme point de départ initial pour les problèmes de capacité de métadonnées.
Symptômes
Symptômes des métadonnées :
Si la limite de capacité de métadonnées a été atteinte ou dépassée, l’ordonnanceur de sauvegarde Avamar peut être suspendu et empêcher l’exécution de nouvelles procédures de sauvegarde planifiées.
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Le tableau de bord de l’interface utilisateur d’Avamar Administrator peut afficher une valeur de capacité de métadonnées supérieure ou égale à 100 %.
- La sortie de ligne de commande du serveur MCS (Management Console Server) affiche une valeur de capacité de métadonnées supérieure ou égale à 100 % :
Exemple de commande et de sortie :
mcserver.sh --status | grep -i metadataUtilization
metadataUtilization (larger of (nstripes/totalStripesPermitted) or (stripeReserved/(nodeSizeAfterDiskReadOnly * stripeUtilizationCapacityFactor)) * 100): 100.3
- Dans l’interface utilisateur d’Avamar Administrator, l’ordonnanceur et le répartiteur sont en état de « suspension ».
- Dans l'
mcserver logfichiers, un message similaire à "FINE : Suspension du répartiteur. »
- À partir d’une requête d’état MCS de ligne de commande, le planificateur est suspendu :
mcserver.sh --status | grep suspend
Backup dispatching: suspended
Introduction :
Dans un environnement Avamar intégrant Data Domain, les sauvegardes peuvent être stockées sur le système Data Domain.
Bien que les données de sauvegarde soient envoyées à et stockées sur Data Domain, Avamar conserve les enregistrements des métadonnées des sauvegardes.
(Dans ce type d’environnement, les métadonnées regroupent les informations sur les fichiers de sauvegarde, les attributs de fichier, les répertoires, etc. du système d’exploitation client.)
Pour plus d’informations, reportez-vous à la Fiche technique sur la création de rapports et la surveillance de la capacité de métadonnées .
Histoire:
- Étant donné que les bases de données ne contenaient que quelques fichiers, Avamar ne pouvait suivre qu’une petite quantité de métadonnées.
- Les sauvegardes de système de fichiers vers Data Domain n’étaient pas prises en charge dans Avamar v6.
- Cela était nécessaire en raison de la prise en charge des sauvegardes du système de fichiers sur Data Domain.
- Avec les sauvegardes de système de fichiers, de nombreux fichiers différents sont sauvegardés, chacun desquels les attributs et métadonnées doivent être suivis par Avamar.
- Étant donné que les métadonnées sont beaucoup plus petites en taille que le contenu du fichier de sauvegarde, elles peuvent s’accumuler et entraîner l’atteinte d’autres types de limites de ressources.
- La capacité de métadonnées a été ajoutée pour protéger le serveur contre ce nouveau type d’utilisation dépassant les restrictions et les limites.
Cause
Il existe généralement l’une des trois situations suivantes lorsque la capacité de métadonnées devient élevée ou constitue un problème :
- Cette situation peut provenir de sauvegardes intentionnelles ou accidentelles sur Avamar plutôt que sur Data Domain
- Cette situation peut également être due à un niveau élevé d’Avamar
GSANcapacité qui s’est produite avant l’intégration de Data Domain.
- Une capacité de métadonnées élevée est signalée à tort, probablement en raison d’une erreur matérielle ou d’une mauvaise configuration.
- Ce processus garantit que si une mise à niveau se poursuit, la grille nouvellement mise à niveau ne passera pas dans un état de capacité de métadonnées complète.
Résolution
1. Connectez-vous à Avamar Utility Node en tant qu’administrateur.
2. Exécutez la commande suivante pour vérifier la capacité élevée ou complète des métadonnées :
mcserver.sh --status | grep -i metadataUtilization
Exemples :
metadataUtilization (larger of (nstripes/totalStripesPermitted) or (stripeReserved/(nodeSizeAfterDiskReadOnly * stripeUtilizationCapacityFactor)) * 100): 95.95
metadataUtilization (larger of (nstripes/totalStripesPermitted) or (stripeReserved/(nodeSizeAfterDiskReadOnly * stripeUtilizationCapacityFactor)) * 100): 100.3
Si l’utilisation n’est pas élevée, arrêtez d’utiliser cet article.
3. Consultez l’article suivant : Avamar : Comment collecter les informations nécessaires au dépannage des problèmes de capacité.
4. Consultez l’article suivant pour vérifier qu’il n’existe aucun autre type de problèmes de capacité Avamar : Avamar : problèmes et questions liés à au dépannage de la capacité - Toutes les capacités (chemin de résolution) (en anglais)
5. Vérifiez qu’un système Data Domain est rattaché en exécutant la commande suivante :
ddrmaint read-ddr-info
Exemples :
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<avamar dpnid="1234567890" type="default" version="5">
<datadomain count="1">
<ddrconfig client-map-default="true" cloud_enabled="true" cloud_unit_name="ECS_Unit1" dd-cert-chain=" -----BEGIN CERTIFICATE----- ..... -----END CERTIFICATE-----" ddos-version="7.7.5.25-1078970" ddrcreatetime="1685672811" ddrid="ABCDEF0C18C7E2D75F20E0A1596E66AA2EE764E9" gsan-backup-target-default="true" hostname="dd.compamy.com" index="1" instant-access-limit="32" ipv4-hostname="dd.compamy.com" ipv6-hostname="" max-streams="50" max-streams-for-cp-backup="2" modelno="DD VE" mtree_name="/data/col1/avamar-1643691765" password="Onlh2XP9xEpvI2exqGQwqA==" policy_id="%2Fdata%2Fcol1%2Favamar-1234567890%3AECS_Unit1" serialno="AUDABCDEFGHIJK" token="AQBpud2RFZVF81Vv6NHMK/Y3jecFGhxv0KUif8BYoNk7iQ==" username="<ddboostuser">
<snmp community="noSejOLJ1lRsg1kEHjWdiA==" version="2">
<ports getter-setter="161" trap="163">
</ports>
</snmp>
<client-map>
</client-map>
<auth-type>credential</auth-type>
</ddrconfig>
</datadomain>
</avamar>
<4774>read-ddr-info: MSG_ERR_NOT_PRESENT: ddr_info does not exist.
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- Si aucun système Data Domain n’est connecté, il s’agit probablement d’un faux positif causé par des erreurs matérielles ou une mauvaise configuration. Contactez le support pour obtenir de l’aide.
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- Si un système Data Domain est rattaché et que les limites de capacité de métadonnées ont été atteintes ou sont très élevées, contactez le support pour obtenir de l’aide.
- Dans la mesure du possible, incluez toutes les informations collectées et tous les détails afin d’accélérer le délai de résolution.
- Dans certains cas, la valeur Capacité de métadonnées peut être réduite en réglant les paramètres.
- D’autres situations peuvent nécessiter de nouvelles limitations ou des modifications matérielles. Le membre de l’équipe de support Dell Technologies Avamar discutera des actions requises.
- Dans la mesure du possible, incluez toutes les informations collectées et tous les détails afin d’accélérer le délai de résolution.
- Si un système Data Domain est rattaché et que les limites de capacité de métadonnées ont été atteintes ou sont très élevées, contactez le support pour obtenir de l’aide.
Informations supplémentaires
Pour plus d’informations sur la façon dont la capacité de métadonnées est représentée, consultez Avamar : La valeur d’utilisation des métadonnées augmente, mais ne diminue jamais