Código do evento Openshift: 1038NODE0003
Résumé: O nó está inacessível.
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Toutes les versions du produit ne sont pas identifiées dans cet article.
Symptômes
O desempenho das implementações de cluster é afetado, dependendo da carga de trabalho geral e do tipo de nó.
Cause
O nó do Kubernetes está inacessível e algumas cargas de trabalho podem ser reagendadas.
Résolution
Diagnóstico
Os detalhes da notificação devem listar o nó que não está acessível. Por exemplo:
- alertname = KubeNodeUnreachable ... - nó = node1.example.com ... |
Faça log-in no cluster. Verifique o status desse nó:
$ kubectl get node $NODE -o yaml |
O resultado deve descrever por que o nó não está acessível.
Cenários comuns de falha:
- Upgrades de software disruptivos
- Paticionamento de rede devido a falhas de hardware
- regras de firewall
- Máquinas virtuais suspensas devido a problemas de storage area network
- O sistema trava/congela devido ao mau funcionamento do software ou hardware
Mitigação
Em caso de manutenção garanta o cordão e drene o nó.
Em outros casos, garanta redundância de armazenamento e rede, se aplicável.
Consulte o KubeNode Ver o detector de problemas do nó Consulte o temporizador do watchdog
Serviço de suporte
Se todas as etapas acima não puderem resolver o problema, entre em contato com o suporte técnico da Dell EMC para investigar mais.
Produits concernés
APEX Cloud Platform for Red Hat OpenShiftPropriétés de l’article
Numéro d’article: 000217419
Type d’article: Solution
Dernière modification: 20 févr. 2026
Version: 3
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