O backup do Oracle do Windows falha com "ORA-01031: Privilégios insuficientes" quando um usuário tem apenas uma função SYSBACKUP.

Résumé: Avamar: O backup do Oracle do Windows falha com "ORA-01031: Privilégios insuficientes" quando apenas o privilégio SYSBACKUP é concedido a um usuário.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

O backup do Oracle do Windows falha com o erro "ORA-01031: Privilégios insuficientes" quando apenas o privilégio SYSBACKUP é concedido a um usuário.

 

O log avoracle indica que o teste do usuário é usado para se conectar a um banco de dados:

++++++++++++++++++++++++++++++++++++
avoracle Info : RMAN is connecting to the Oracle DB as the DB user 'test'
avoracle Info : RMAN=c:\work\windows.x64_193000_db_home\bin/rman
avoracle Info : RMAN=c:\work\windows.x64_193000_db_home\bin/rman
avoracle Error : Snapup of ORCL aborted due to rman terminated abnormally - check the logs
++++++++++++++++++++++++++++++++++++

O registo do Recovery Manager (RMAN) indica que o utilizador não tem privilégios suficientes e não consegue estabelecer a ligação:

++++++++++++++++++++++++++++++++++++
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
ORA-01031: insufficient privileges

Recovery Manager complete.
++++++++++++++++++++++++++++++++++++

 

Cause

Isto ocorre devido a uma falha de software no plug-in Avamar Windows avoracle.

 

Résolution

Atualizar o Servidor Avamar para a versão 19.8.100-83 ou posterior. A correção é incorporada no Avamar 19.8 e versões posteriores do software.

 

Vidéos

N/A
Propriétés de l’article
Numéro d’article: 000202697
Type d’article: Solution
Dernière modification: 11 juin 2024
Version:  7
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.