Windows Oracle-sikkerhetskopiering mislykkes med ORA-01031: Ikke tilstrekkelige rettigheter" når en bruker bare har en SYSBACKUP-rolle.

Résumé: Avamar: Windows Oracle-sikkerhetskopiering mislykkes med ORA-01031: Utilstrekkelige rettigheter" når bare SYSBACKUP-privilegiet er gitt til en bruker.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Windows Oracle-sikkerhetskopiering mislykkes med feilen ORA-01031: Utilstrekkelige rettigheter" når bare SYSBACKUP-privilegiet er gitt til en bruker.

 

Avoracle-loggen indikerer at brukertesten brukes til å koble til en database:

++++++++++++++++++++++++++++++++++++
avoracle Info : RMAN is connecting to the Oracle DB as the DB user 'test'
avoracle Info : RMAN=c:\work\windows.x64_193000_db_home\bin/rman
avoracle Info : RMAN=c:\work\windows.x64_193000_db_home\bin/rman
avoracle Error : Snapup of ORCL aborted due to rman terminated abnormally - check the logs
++++++++++++++++++++++++++++++++++++

Recovery Manager (RMAN)-loggen indikerer at brukeren ikke har tilstrekkelige rettigheter, og ikke kan opprette tilkoblingen:

++++++++++++++++++++++++++++++++++++
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
ORA-01031: insufficient privileges

Recovery Manager complete.
++++++++++++++++++++++++++++++++++++

 

Cause

Dette skjer på grunn av en programvarefeil i Avamar Windows avoracle-plugin-modulen.

 

Résolution

Oppgrader Avamar Server til versjon 19.8.100-83 eller nyere. Feilrettingen er inkludert i Avamar 19.8 og nyere programvareversjoner.

 

Vidéos

N/A
Propriétés de l’article
Numéro d’article: 000202697
Type d’article: Solution
Dernière modification: 11 juin 2024
Version:  7
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.