PowerMax 2500 e 8500: O host não consegue detectar o PowerMax usando NVMe/TCP

Résumé: O host não consegue detectar e se conectar ao PowerMax quando um endpoint NVMe/TCP (IPPT) no PowerMax é configurado no modo Advertise Direct Discovery Controller (DDC).

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Níveis do PoweMaxOS afetados: 
  • 10.0.0.0 (Juniper)
  • 10.0.1.0 (Juniper-SR1)
  • 10.0.1.x (Juniper-SR1-hotfix)
Isso afeta os hosts que usam nvme-stas ou uma ferramenta semelhante que usa mDNS para detectar e se conectar ao PowerMax.


O seguinte comando no host Linux pode encontrar os serviços anunciados:

 
avahi-browse -t -v _nvme-disc._tcp
 
image.png

Use o seguinte comando para resolver a falha do domínio (opção -r).
avahi-browse -t -r -v _nvme-disc._tcp
 
image.png

Cause

O problema é o registro de serviço (SRV) do servidor de nome de domínio (DNS) (https://en.wikipedia.org/wiki/SRV_record).
Os registros SRV têm um campo chamado "destino", o destino é o nome de host da entidade que fornece o serviço. O host pode usar esse hostname para recuperar o endereço IP. No PowerMax, esse mecanismo não funcionou porque o "destino" apontava para o nome de host errado, conforme mostrado na resposta de consulta a seguir.

image.png
 

Além do problema acima, o registro de recursos RR_TXT estava vazio na resposta à consulta causada por um problema de formatação ao criar a resposta de consulta.

Résolution

O problema é resolvido com a seguinte correção em Juniper-SR1-Hotfix:
10.0.1.x (Juniper-SR1-hotfix) - PMOS-59142

Solução temporária:
configure manualmente o endereço IP do DDC, o endereço IP associado ao IPPT no host.

Produits concernés

PowerMax 2500, PowerMax 8500
Propriétés de l’article
Numéro d’article: 000217103
Type d’article: Solution
Dernière modification: 20 août 2025
Version:  6
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.