PPDM: SQL AppAware-konfiguration (VM Direct) mislykkes på grund af proxy- og portproblemer

Résumé: SQL AppAware-konfigurationen (VM Direct) i PowerProtect Data Manager (PPDM) mislykkes på grund af proxygodkendelsesfejl og netværksportbegrænsninger. Problemet skyldes typisk blokeret kommunikation mellem PPDM-serveren, mål-VM'en og Data Domain-systemet. ...

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Berørte produkter:

  • PowerProtect Data Manager (PPDM)

Symptomer:

  • SQL AppAware-konfiguration (VM Direct) mislykkes under installationen
  • Fejl i PPDM:
    • Unable to register PowerProtect Agent Service. 
      HTTPSConnectionPool(host='PPDM-server-ip', port=8443): Max retries exceeded with url: /api/v2/adm/agentRegistration 
      (Caused by ProxyError('Cannot connect to proxy.', OSError('Tunnel connection failed: 407 Proxy Authorization Required')))
  • Installationen af vProxy Agent mislykkes med:
    • Command 'C:\Windows\system32\msiexec.exe' terminated with exit code 1601

Cause

  • Port 7000 kan ikke nås fra PPDM-serveren til destinations-VM'en
  • Der mangler administratorrettigheder til udrulning af SQL AppAware-agenten i VM'en
  • Proxykonfiguration blokerer udgående kommunikation, hvilket resulterer i fejlen 407 Proxy Authorization Required

Résolution

Sådan løses problemet:

  1. Sørg for netværksforbindelse:

    • Åbn port 8443 fra VM'en til PPDM-serveren
    • Åbn port 111, 2049 og 2052 fra VM'en til Data Domain-systemet
    • Åbn port 7000 fra PPDM til mål-VM en
  2. Brug administratorlegitimationsoplysninger til FLR-agenten under SQL AppAware-konfiguration

  3. Gennemgå proxyindstillingerne for at sikre, at PPDM-serveren kan kommunikere eksternt uden proxygodkendelsesfejl

 

Bemærk: VM Direct udfører sikkerhedskopier på blokniveau, mens SQL AppAware bruger en intern agent til sikkerhedskopieringer af SQL-transaktionslogfiler. Begge komponenter kræver uafbrudt kommunikation med PPDM- og DD-systemer.

Produits concernés

PowerProtect Data Manager, PowerProtect App Direct, PowerProtect Software
Propriétés de l’article
Numéro d’article: 000321643
Type d’article: Solution
Dernière modification: 03 oct. 2025
Version:  1
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.