Plate-forme de gestion PowerFlex : La ressource de la passerelle indique que PowerFlex est inaccessible
Résumé: La ressource de la passerelle PowerFlex affiche une alerte indiquant que le système PowerFlex est inaccessible.
Symptômes
Scénario
Le système PowerFlex back-end est toujours sur le logiciel 3.x et a été importé dans le système PowerFlex Manager 4.x.
Impact
Impossible d’effectuer une mise à niveau réussie de la passerelle PowerFlex.
Cause
Dans PowerFlex Manager, il existe deux pods de passerelle responsables des demandes d’équilibrage de charge. Alors que le système back-end est sur la version 3.x, la passerelle utilise un jeton pour l’authentification avec le MDM. Toutefois, le jeton d’authentification est stocké sur une seule des passerelles. Par conséquent, lorsque plusieurs appels consécutifs sont effectués, la fonction d’équilibrage de charge peut diriger certains appels vers la passerelle sans le jeton de connexion, ce qui entraîne l’échec de ces appels. Cette défaillance entraîne une alerte de la ressource de passerelle indiquant que le système PowerFlex est inaccessible.
Résolution
Déposez le ReplicaSet des passerelles PowerFlex vers une seule passerelle :
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Établissez une connexion SSH avec l’un des hôtes de la plate-forme de gestion PowerFlex
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Réduisez le nombre de réplicas à 1 :
kubectl scale sts block-legacy-gateway -n powerflex --replicas=1
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Effectuez la mise à niveau de la passerelle. Cela met à niveau le système vers la version 4.x où MTLS est utilisé et ce problème n’est pas observé.
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Une fois que le système PowerFlex back-end est mis à niveau vers la version 4.x, réglez le jeu de réplicas sur 2 pour la passerelle :
kubectl scale sts block-legacy-gateway -n powerflex --replicas=2
Version concernée
PowerFlex Manager 4.x
Problème résolu dans la version
PowerFlex Manager 4.6.1