Sikkerhetskopiering av PowerFlex Manager 3.x mislykkes med feilmeldingen Kunne ikke sikkerhetskopiere database

Résumé: Sikkerhetskopiering av PowerFlex Manager 3.x mislykkes med feilmeldingen Kunne ikke sikkerhetskopiere database.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Sikkerhetskopiering av PowerFlex Manager 3.x mislykkes med følgende feil:
AsmManager.log shows
2024-08-01 04:33:42 [JobMgrQuartzScheduler_Worker-56] (BackupDatabaseJob.java:122) [ERROR] Backup Database Job : Failed to Backup Database
2024-08-01 04:33:42 [JobMgrQuartzScheduler_Worker-56] (AsmDefaultJob.java:74) [ERROR] Backup Database Job : Failed to Backup Database
[vxfm-es-node-1] failed to put mappings on indices [[[snmp-traps-2024.07.31/9Kcv1tM0Tn2dN061eVfpLQ]]], type [snmptraps]
java.lang.IllegalArgumentException: Limit of total fields [2000] in index [snmp-traps-2024.07.31] has been exceeded

Cause

Sikkerhetskopieringer kjørte ikke på grunn av at indeksene vokste for raskt.

Kommandoen nedenfor viser at syslog-indeksen vokser raskt:
curl 'localhost:9200/_cat/indices?v'

Merk: Slettede syslog-indekser sjekket deretter igjen, og den fortsatte å vokse i raskt tempo.
 
Skjermbilde av syslog-indekser 

Résolution

Fremgangsmåte:
  1. Bekreft statusen til indekser med følgende kommando:
curl 'localhost:9200/_cat/indices?v'
  1. Kontroller statusen, og stopp tjenesten med følgende kommandoer:
systemctl status rsyslog

systemctl stop rsyslog
  1. Slett syslog-indeksene med følgende kommando:
curl -X DELETE ' http://localhost:9200/syslog*'
  1. Kjøring av følgende kommando viser ikke syslog fordi tjenesten har stoppet:
curl 'localhost:9200/_cat/indices?v'
  1. Kjør sikkerhetskopien på nytt, så skal den fungere. Når sikkerhetskopieringen er fullført, starter du tjenesten:
systemctl start rsyslog

Hvis du vil kontrollere live-status for sikkerhetskopieringsfremdriften, bruker du følgende kommando på PFxM CLI:
tail -f /opt/Dell/ASM/logs/asmManager.log
Propriétés de l’article
Numéro d’article: 000227742
Type d’article: Solution
Dernière modification: 02 janv. 2026
Version:  2
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.