PowerFlex Manager 3.x-Backup schlägt mit dem Fehler "Datenbank konnte nicht gesichert werden" fehl
Résumé: PowerFlex Manager 3.x-Backup schlägt mit dem Fehler "Failed to Backup Database" fehl.
Cet article concerne
Cet article ne concerne pas
Cet article n’est associé à aucun produit spécifique.
Toutes les versions du produit ne sont pas identifiées dans cet article.
Symptômes
PowerFlex Manager 3.x-Backup schlägt mit den folgenden Fehlern fehl:
AsmManager.log shows 2024-08-01 04:33:42 [JobMgrQuartzScheduler_Worker-56] (BackupDatabaseJob.java:122) [ERROR] Backup Database Job : Failed to Backup Database 2024-08-01 04:33:42 [JobMgrQuartzScheduler_Worker-56] (AsmDefaultJob.java:74) [ERROR] Backup Database Job : Failed to Backup Database [vxfm-es-node-1] failed to put mappings on indices [[[snmp-traps-2024.07.31/9Kcv1tM0Tn2dN061eVfpLQ]]], type [snmptraps] java.lang.IllegalArgumentException: Limit of total fields [2000] in index [snmp-traps-2024.07.31] has been exceeded
Cause
Backups wurden nicht ausgeführt, da Indizes zu schnell wuchsen.
Der folgende Befehl zeigt, dass der Syslog-Index schnell wächst:
Hinweis: Die gelöschten Syslog-Indizes wurden dann erneut überprüft und es wuchs weiterhin in rasantem Tempo.
Der folgende Befehl zeigt, dass der Syslog-Index schnell wächst:
curl 'localhost:9200/_cat/indices?v'
Hinweis: Die gelöschten Syslog-Indizes wurden dann erneut überprüft und es wuchs weiterhin in rasantem Tempo.
Résolution
Verfahren:
Um den Livestatus des Backupfortschritts zu überprüfen, verwenden Sie den folgenden Befehl in der PFxM-CLI:
- Überprüfen Sie den Status von Indizes mit dem folgenden Befehl:
curl 'localhost:9200/_cat/indices?v'
- Überprüfen Sie den Status und beenden Sie den Service mit den folgenden Befehlen:
systemctl status rsyslog systemctl stop rsyslog
- Löschen Sie die Syslog-Indizes mit dem folgenden Befehl:
curl -X DELETE ' http://localhost:9200/syslog*'
- Beim Ausführen des folgenden Befehls wird syslog nicht angezeigt, da der Service beendet wurde:
curl 'localhost:9200/_cat/indices?v'
- Führen Sie das Backup erneut aus und es sollte funktionieren. Sobald das Backup abgeschlossen ist, starten Sie den Service:
systemctl start rsyslog
Um den Livestatus des Backupfortschritts zu überprüfen, verwenden Sie den folgenden Befehl in der PFxM-CLI:
tail -f /opt/Dell/ASM/logs/asmManager.log
Propriétés de l’article
Numéro d’article: 000227742
Type d’article: Solution
Dernière modification: 02 janv. 2026
Version: 2
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.