Rotbruker kan ikke logge på WebUI/CLI i 8.x når standarddomenet er angitt

Résumé: Duplisert rotbruker i domenet forårsaker problemer med å logge på klyngen via webgrensesnitt og CLI.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Når du logger på klyngen, mislykkes enten via webgrensesnittet eller CLI, med passordfeil.

Dette gjelder for OneFS 8.x når det er en duplisert bruker (for eksempel root) på domenet.

Du kan fortsatt logge på med unix_users-domenet:

UNIX_USERS\root

Bekreft om det aktuelle domenet er satt til standarddomenet:

#isi auth ads view --provider-name=<domain> --verbose | grep "Assume Default Domain"
    Assume Default Domain: Yes

 

Cause

Hvis standarddomenet er angitt, må OneFS først kontakte domenet for å godkjenne den lokale brukeren. I dette tilfellet bruker vi root. Hvis brukeren finnes på domenet, prøver OneFS å godkjenne brukeren via domenet.

Hvis kontoen er deaktivert, ser du en feilmelding når du prøver å logge på.

 

Résolution

I 8.x kan du legge til brukere som ikke kan finnes, i en hvilken som helst domenekontroller ved hjelp av følgende kommando:

# isi auth ads modify --provider-name=<domain> --add-unfindable-users=<list of users we don't want found(to include domain name and FQDN) --restrict-findable=yes

For å sikre at innstillingene er gjort, kjør autorisasjonsvisningen på nytt:

# isi auth ads view --provider-name=<domain> --verbose
--you are looking for this output:
         Unfindable Users: <FQDN>\root, <Domain>\root, 0, root
          Findable Groups: -
           Findable Users: -
        Restrict Findable: Yes

For at klyngen skal sikre at den filtrerer ut brukerne som ikke kan finnes, den begrensbare søkbarheten være slått på.

 

Propriétés de l’article
Numéro d’article: 000050102
Type d’article: Solution
Dernière modification: 17 Apr 2026
Version:  5
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.