AppSync:Postgresのアップグレードが失敗する

Summary: AppSync:Postgresのアップグレードが失敗する

Ez a cikk a következő(k)re vonatkozik: Ez a cikk nem vonatkozik a következő(k)re: Ez a cikk nem kapcsolódik egyetlen konkrét termékhez sem. Ez a cikk nem azonosítja az összes termékverziót.

Symptoms

PostgresはKB 000504125ごとにアップグレードされていますが、Postgresのアップグレードに失敗します

appsync_dbupgrade.logには、次の情報が表示されます。
 

Command.run()を使用します。C:\Users\userid\AppData\Local\Temp\2\011266.tmp\executeScriptTmp0.bat:stdout [Failure, exiting]
Command.complete(): process completed with exit code: 1


pg_upgrade_utility.logには次の情報が表示されます。
 

コマンド:xcopy /e /y /q /r "E:\EMC\AppSync\jboss\datastore\data/pg_clog" "E:\EMC\AppSync\NewDatastore\data/pg_clog\" >> "pg_upgrade_utility.log" 2>&1
無効なドライブ指定
0 コピーされたファイル


注:%AppData%にあるpg_upgrade_utility.logは、アップグレード ダイアログ中にアップグレード失敗のメッセージが表示されたときに[OK]をクリックすると削除されます。そのため、[OK]をクリックしてアップグレード ダイアログを開く前に、このファイルを収集する必要があります。

手記:AppSyncデータベースは、デフォルト以外の場所(この例ではE:ドライブ)に存在します。

Cause

トリガーは、正確な原因が不明な権限関連の問題です。
アップグレード ユーティリティーが管理者として実行されています。アップグレード ユーティリティーが右クリック方式で管理者として実行されたときにログインしているユーザーは、E:ドライブに対するフル権限を持つローカル管理者グループに存在するドメイン管理者です。

いずれにせよ、デバッグに procmon を使用すると、ログインしているユーザーが E: ドライブにアクセス許可エラーが表示されます。

Resolution

アップグレード プロセスの実行時にログインしている特定のユーザーのE:ドライブに対する完全な管理者権限を明示的に付与します。

Érintett termékek

AppSync

Termékek

AppSync
Termék tulajdonságai
Article Number: 000057208
Article Type: Solution
Utoljára módosítva: 19 szept. 2025
Version:  6
Választ kaphat kérdéseire más Dell-felhasználóktól
Támogatási szolgáltatások
Ellenőrizze, hogy a készüléke rendelkezik-e támogatási szolgáltatással.