PowerFlex:无法运行 ScaleIO 命令。Error: MDM failed command
Summary: 无法运行 ScaleIO 命令,错误:“MDM failed command.Status:会话登录无效,然后重试。”
Ez a cikk a következő(k)re vonatkozik:
Ez a cikk nem vonatkozik a következő(k)re:
Ez a cikk nem kapcsolódik egyetlen konkrét termékhez sem.
Ez a cikk nem azonosítja az összes termékverziót.
Symptoms
尝试从主元数据管理器 (MDM) 运行命令时,ScaleIO 命令失败并显示无效会话:
# scli --mdm_ip --login --username admin Enter password: Logged in. User role is Administrator. System ID is XXXXXXXXX # scli --mdm_ip --query_all_volumes Error: MDM failed command. Status: Invalid session. Please login and try again.
Cause
导致 MDM 拒绝连接的问题是 CallHome 用户“Monitor”每十分钟再次登录一次,并且未注销。这会导致用户登录会话累积并填满会话表,然后硬超时才会踢出它们。
Resolution
删除(或注释)以下两行: mdm/cfg/conf.txt,在两个 MDM 上:
user_session_hard_timeout_secs=86400 user_session_timeout_secs=28800 Stop CallHome service temporarily
/opt/emc/scaleio/callhome/bin/delete_service.sh
重新启动 MDM 服务:
kill
等待 10 分钟,然后尝试发出 scli 命令,然后再次启动 call-home 服务。
./opt/emc/scaleio/callhome/bin/create_service.sh
Additional Information
如果 ScaleIO CLI 会话超时,也会出现此错误。
Érintett termékek
PowerFlex SoftwareTermékek
PowerFlex SoftwareTermék tulajdonságai
Article Number: 000065938
Article Type: Solution
Utoljára módosítva: 08 jan. 2026
Version: 6
Választ kaphat kérdéseire más Dell-felhasználóktól
Támogatási szolgáltatások
Ellenőrizze, hogy a készüléke rendelkezik-e támogatási szolgáltatással.