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How to troubleshoot Performance, Display, Network issues with Dell Universal Dock (D6000 series)

Summary: Having network, display or performance issues with your Dell Universal Dock (D6000 series)? Learn how to troubleshoot and resolve performance, display, network, and other issues with your Dell Universal Dock (D6000 series). ...

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Article Content


Symptoms

If you are noticing one of the following symptoms when using a Dell Universal Dock (D6000 series) with your Dell laptop, follow the steps below.

  • The docking station is unresponsive, or the performance lags.
  • Intermittent connection with the laptop.
  • Multiple monitors do not work.
  • Flickering or flashing display when connected to the docking station.
  • Intermittent network connectivity.
  • Unable to charge the laptop.

Cause

Dell Universal Dock (D6000 series) uses DisplayLink software to work with USB-C (DisplayLink alternate mode or Thunderbolt 3) or USB 3.0 (Type-A) port of a laptop.

Resolution

If the Dell Universal Dock (D6000 series) is already connected to the laptop, ensure to uninstall the DisplayLink driver and application from the laptop before disconnecting the dock.

  1. Press Windows and R key on the keyboard.
  2. In the Run dialog box, type appwiz.cpl and press Enter key.
  3. In Programs and Features (formerly Add/Remove Programs) window, select the DisplayLink option and click Uninstall.
  4. Once the uninstallation is complete, turn off the computer.
  5. Disconnect the Dell Universal Dock D6000 from the computer.
  6. Turn on the computer.

Download and install the latest chipset, USB 3.0, and video card (GPU) drivers.

NOTE: After the driver is installed, ensure to the restart the computer when prompted.
NOTE: To learn more, see the Dell knowledge base article How to Download and Install Dell Drivers.
  1. Browse to the Dell Drivers & Downloads website.
  2. Identify your Dell laptop.
    • Click Download & Install SupportAssist to auto-detect your Dell laptop. Follow the on-screen instructions to install Dell SupportAssist. For more information, see the Dell knowledge base article Dell SupportAssist (formerly Dell System Detect): Overview and Common Questions.
    • Or, enter the Service Tag, Express Service Code, or the Serial number of the Dell laptop and click Search.
    • Or, click Browse all products to manually select your Dell laptop from the catalog.
  3. Select the operating system that is installed on the laptop.
  4. Download and install the following drivers:
    • Chipset - The chipset drivers are available under the Chipset category. There may be multiple chipset drivers that are applicable for your laptop. Download and install all the chipset drivers. If you receive a message that a driver is not applicable or a newer version is already installed, go to the next drive.
    • USB 3.0 - The USB 3.0 controller driver is available under the chipset category. If a USB 3.0 driver is not listed for your Dell laptop, go to the next step.
    • Video card (GPU) - The video driver is available under the video category.
  5. Next, browse to the DisplayLink website, download, and install the latest DisplayLink application.
  6. Restart the laptop when prompted.
  7. Connect the Dell Universal Dock (D6000 series) to the laptop.
    NOTE: When the Dell Universal Dock (D6000 series) is connected to the laptop, the installation may take up to five minutes or more.
  8. Once the installation is complete, restart the laptop.

Download and install the latest firmware of the docking station.

  1. Browse to the Dell Drivers & Downloads website.
    1. Dell Universal Dock D6000
    2. Dell Universal Dock D6000S
  2. Download and install the latest firmware for Dell Universal Dock (D6000 series). If a firmware update is not available, skip this step.
    WARNING: Do not turn off the docking station or the laptop during the firmware update process.
NOTE: Dell recommends turning off the docking station when it is not in use. If the Dell D6000 series docking station is continuously turned on, as a best practice, turn off the docking station for two minutes before turning it on again.

Additional Information

For additional help, see the Dell knowledge base article How to Use and Troubleshoot Dell Universal Dock (D6000 series).


Out of Warranty support Out of warranty? No problem. Browse to the Dell.com/support website and enter your Dell Service Tag and view our offers.

NOTE: Offers are only available for US, Canada, UK, France, Germany, and China, personal computer customers. Server and Storage not applicable.

Article Properties


Affected Product

Dell Universal Dock D6000, Dell Universal Dock - D6000S

Last Published Date

28 júl. 2021

Version

5

Article Type

Solution