Dell Unity. Настройка пользовательского баннера с svc_banner завершается сбоем с ошибкой разрешения.

Summary: Пользователи, выполняющие процедуру настройки пользовательского баннера с помощью команды svc_banner, описанную в разделе Семейство Dell Unity — технические заметки к сервисным командам, сталкиваются с ошибками разрешений. ...

Ez a cikk a következő(k)re vonatkozik: Ez a cikk nem vonatkozik a következő(k)re: Ez a cikk nem kapcsolódik egyetlen konkrét termékhez sem. Ez a cikk nem azonosítja az összes termékverziót.

Symptoms

Пользователи, выполняющие процедуру установки пользовательского баннера с помощью метода svc_banner команда, описанная в Семействе Dell Unity — Технические заметки к сервисным командам (стр. 6 и 7), приводит к ошибкам разрешений.

В соответствии с документацией, пользователям рекомендуется поместить текстовый файл пользовательского шаблона в /home/service directory И при попытке сделать это они получают ошибку отказа в разрешении. 

Снимок экрана с сообщением об отказе в разрешении

Cause

Это так, как задумано. 
Переменная /home/service Каталог доступен только пользователям, которые внедрили корневой каталог.

Resolution

Вместо этого пользователи должны использовать метод /home/service/user Каталог, доступный сервисному пользователю и не требующий прав root.
  1. Создавайте текстовые файлы в /home/service/user каталог с локализованным содержимым с именем:
    • Для английского:en_US.txt
    • Для белорусского: be_BY.txt
    • Для китайского:zh_CN.txt
  2. Чтобы применить эти файлы, выполните следующую команду от имени сервисного пользователя:
svc_banner --put en_US.txt be_BY.txt zh_CN.txt
Если выполнен вход в Unisphere, выйдите из системы, а затем войдите снова. Должен появиться новый баннер. 

Пример. 

Снимок экрана вывода команды
Снимок экрана тестового баннера
 
 

Érintett termékek

Dell EMC Unity
Termék tulajdonságai
Article Number: 000219224
Article Type: Solution
Utoljára módosítva: 16 szept. 2025
Version:  3
Választ kaphat kérdéseire más Dell-felhasználóktól
Támogatási szolgáltatások
Ellenőrizze, hogy a készüléke rendelkezik-e támogatási szolgáltatással.